Help (really) needed Streamdeck + Notation Express

I have a bad one here.

I was using Streamdeck no problem with Notation Express for Dorico 4. One morning it stopped working (I later found out that this is because they updated Streamdeck Mobile).

What followed was 19 days of back and forth between Elgato email ‘support’ and me. I did everything they asked, with no results. Then one day I get an email from some new person at Elgato saying ‘we just patched the mobile app, try now’. And it worked… sort of. SD Mobile is now seeing my computer. But what shows is something weird. See Screenshots 1a and 1b (these are from my mobile device, taken from the SD Mobile app).

So I contacted Philip at NYC Music Services and sent him some screenshots and he sent me Screenshot 2 and said “I don’t see NE for Dorico 4 under the ‘Custom’ tab in the left SD desktop panel”. And this makes sense because when I was reinstalling NE using the YT video that Philip made, I didn’t see Custom in there either. In fact, I don’t see Custom, Control Center or OBS Studio in my left hand panel, all of which I see in Philip’s screenshot

In the SD Mobile app I can see that it knows I am a paying customer. Could it be that the Desktop app doesn’t? I have asked Elgato support about this and they have no response, they just keep saying ‘please contact the vendor of the software you’re using’. It’s fairly frustrating! I tried calling Elgato supoprt maybe 10 times, it’s just a recorded message saying ‘Call back’.

Sorry this is so long. Does anyone have any insight here?

Paging @davemacdo as he’s now more involved than I am in Notation Express for Dorico development…

1 Like

The lock icons in your Stream Deck Mobile screenshots appear to show that the app is behaving as though you are not paying.

Hi and thanks for checking in. I am definitely paying - as mentioned the SD/NE system was working perfectly up until it suddenly stopped. Here’s a screenshot of my Pro Subscription page from the SD Mobile app

Could you try rebooting your device? Those lock icons correspond to not having Pro. You get the equivalent of a Stream Deck Mini for free, which is why you don’t have the lock on the six buttons in the top right corner.

Also, is the Stream Deck desktop screenshot yours or one from Philip? If the latter, could you send a screenshot of your desktop app? The plugins are listed on the right (not the left).

1 Like

Again, thanks so much for taking the time here. I know this is supposed to be Elgato’s gig but I just can’t get anywhere with them. When I say I’ve been trying for 19 days, what I mean is 24 days.

Attached are a few screenshots. The first one of my SD Desktop cuts off a few items from the last tab ‘Navigation’ but this is essentially all I see. The next is what I see when I first launch the SD Mobile app on my phone. It looks just like SD with NE used to look, but when I click on a ‘tile’, I get the questions marks.

I also clicked the gear icon on the desktop app. Screenshots 3 and 4 are what I see under the Devices and Accounts tabs.

Rebooted my phone and my desktop. No luck unfortunately. Also, when Streamdeck Mobile suddenly started working a few days ago, I saw a screen saying something like ‘Restore Purchase’, which I did. When I told Elgato this, they said ‘send a screenshot of what you see when you click Restore Purchase’. I explained to them that as I had already Restored my Purchase, I no longer see that option. They didn’t respond.

Ok, this is really useful! First, it looks like your mobile app is now working as Pro, which is one important step. Second, it looks like you have the Stream Deck profile installed, but not the Stream deck plugin. Those are two separate things. If you have the profile, you’ll get the buttons like you see in the mobile app, but no functionality. If you don’t have a custom section on the right with a Notation Express item inside, you don’t have the plugin installed. You may need to download it again from Notation Central.


Okay thanks! Philip asked about the same thing, and I mentioned that when I went to try to get this all running again a couple days ago, I had d’loaded the plug in from the email I got when I upgraded to NE for Dorico 4. However, maybe it will help if I just re-do that process. I followed the steps in Philip’s YT video but got stymied when it asked me to make sure that ‘NE for Dorico 4’ was visible under the ‘Custom’ tab’ in the right side of SD desktop.

Maybe I have to uninstall and delete the NE plugin installer I d’loaded yesterday? In any case I am running out the door, I will try to play around late tonight and report back here.

1 Like


For some unknown reason, re-doing the process has worked! No idea what happened, I followed the instructions in the YT video to the letter again. I am crossing every finger and toe in the hope that it keeps working.

Thanks for the help as always.


1 Like

Excellent! Glad you got it going!