Help requested: tempi/metronome marks not recognized

Hello Dorico community,

I installed Catalina and I can’t get Dorico to recognize tempos in this piece (enclosed a portion of it). It’s possible it’s not Catalina at all but either a setting I changed or a file I deleted (long story but I was having system hangs for some audio file conflict and may have gone a little overboard deleting…)

So far I’ve installed the newest Note Performer and updated Dorico to Using an iMac Pro with 10.5.1

Any suggestions?

Thanks very much in advance for any and all help.
Dorico tempo issue (1.08 MB)

I haven’t opened your file, but my best guess is you’ve clicked the blue quarter/crotchet on the right hand side of the top panel, thus turning on fixed tempo mode. Click it again to turn it off.

Thanks–I looked at that but it makes no difference if it’s on or off–it always begins q=120 and doesn’t change from that tempo.

I’ve opened the file now. Aside from the rit. at bars 35-38, none of the tempi are actually tempi - they’re just Shift+X text. They need to be reinserted as Shift+T Tempo text.

Ah! I was sure I entered it otherwise. Thanks so much for looking–I understand it now.

(Strangely, I think they were originally entered as tempi but I made changes to fonts, etc… I’ll look into whether or not that changed their setting from tempi to text)

I’m sorry, DSL, but I am quite confident this kind of “shift” is not possible in Dorico. A text item cannot be changed into a tempo marking (understandable by Dorico). That’s because of the semantic approach taken by the devs in this program. If you want a marking to be recognized as a tempo, you have to use the shift T popover or the appropriate right panel tool. The text tool or the system text tool are not semantically linked to any specific musical property. They’re useful when we need to input something that the semantics in Dorico do not provide (yet), or as a workaround when we need to input things in a very specific way that has not been implemented (yet).

Thanks for your help, Marc. I was just perplexed because I did have playback at one point, which means I went through and changed all the tempi to text inputs somewhere along the way and must just not remember that in my old age. But that’s why I didn’t go in and check because I had remembered it playing back correctly.

Good to know they can’t transform–that can be useful as it is in Sibelius where you can redefine just about any text. But then it can be easy to mess things up, too.

Thanks again for help on this thread.