Help setting up external midi clock and cubase 11 pro

On my windows 10 system with cubase 11 as my daw I have serious midi jitter. Syncing arps on some synths like the system-8 is terrible and audible. So I looked into the option of getting an external midiclock device. I got an ERM midiclock Plus unit which is spot on. No more midi jitter when connected to the system-8. But, how can I get this in my setup? Cubase doesn’t accept an external midi clock. Or is what I want not possible?

Cubase cannot lock to MIDI clock.
You should eliminate the jitter in the first place. Any decent windows PC should be able to feed steady enough midi clock to midi interfaces. Perhaps there were some configuration error in the first simple set up.

Ok . Thanks. Its a dedicated audio PC with only top components, rme audio, midex midi interface. But USB is what’s causing problems.

I assume you had used the midex’s output? How did you set up the external device?

I use midex8, rme and other various usb compliant midi interfaces, any of them are solid enough to drive drum machines, etc. I also have a SND ACME4 midi clock master device. You wouldn’t normally feel any difference in groove between the rock solid acme4 and other midi interfaces. Also had never seen such jittery MIDI clock coming out from cubase in many different situations and setups. So your case, I bet it is some kind of configuration error perhaps within a few settings in cubase.