Help. Waveforms flicker when zooming

After fiddling with sys preferences, I messed up cubase’s zoom in/out, and after restoring the preferences it still didn’t fix it. When zooming in or out the waveforms disappear or flicker.

disable “quick zoom”

Thank You Thank You Thank You !!!

You´re welcome

also one more zoom inconvenience that happened after i played with the preferences.
when opening key editor it zooms to the top. I used to have it that it zooms at the place where the notes are