Help with DAW and software integration

Hello kind strangers,

I hope this message finds you well. It’s unfortunate that my first post has to be a long (and possibly played out) cry for help. That being said I hope to give back what is offered to me, and possibly help someone in a similar situation.


I have been struggling with performance issues with my DAW for some time now.


Mac Pro Mid 2010
OS X 10.7.5
2.87 GHz Quad-Core Intel Xeon
16GB 1066 MHz DDR3
Apogee Quartet (just recently upgraded from older duet)
Akai MPK-49 Midi controller
Cubase 6.5 (I purchased 6.0 and soon after got a free upgrade to 6.5)
NI Komplete 8

I’ll leave off any mics/pres/outboard, as I think they are irrelevant to my issues. I’m fairly new to the more advanced DAW setup, so I’ll apologize in advance if my language or explanations are clunky or unnecessarily detailed. I’ll also mention that I have read many forum posts in trying to resolve this, so many of the more obvious configurations have been attempted (buffer size, sample rate etc) to little avail.

Basically, I feel that I have more than enough power to run basic or even large projects that utilize multiple VST instruments. Yet, I consistently run into issues with performance. I know that VST’s are notoriously taxing but I thought I had enough power to reduce their impact. I’m not sure if the asio meter in ‘VST performance’ is always the best indicator but it seems to go up pretty quickly when I start to add plugins and especially with VST from Komplete 8. I recently read that multi core systems often work one core at a time. So when I look at my activity monitor it will say Cubase is using around ‘50% CPU’ and 4-5GB of ‘Real Mem’. It was explained that this is just the percentage of 1 out of 4 total cores. This make sense in that the ‘% idle’ for total CPU remains high. Essentially, each core would contribute 25% to the total CPU, I think?

A project consisting of a few audio tracks, a few instrument tracks and a couple midi tracks can create a noticeable strain on the system. I start to get minor clicks and pops. It’s not maxing out anything but it just seems to respond more slowly. Every time I hit the spacebar to start or stop there is a slight pop. (Perhaps this is just the reverb plugin or something?)

I upgraded interfaces hoping that might improve performance. There does seem to be a slight improvement, but not enough to avoid posting a long and boring thread on the NI forum.

Here are a few questions I have and, of course, any and all advice or recommendations would be very much appreciated. This is really slowing down my workflow and I’d be so relieved to rectify these issues.

Anything about my general setup that seems problematic or worth upgrading?
Are there any basic settings (within OS X or Cubase) that would boost performance?
Is there anything that stands out with my version of Cubase that might play a role? Possible update or reinstalling the original 6.0?
Is there an ideal way of installing Komplete 8 for best performance?
Might I greatly benefit from installing an SSD drive? (or reallocating the library elsewhere)
The programs receive midi but part of me feels like my controller might not be setup in the ideal manner. I get a little confused about ports and connections in general. Possible that improper routing could cause performance issues, even though I clearly get a signal?

I very much appreciate anyone that takes the time to read this and weigh in. I would be happy to reimburse someone (via paypal etc) that thinks they can help but does’t have a ton of time. Maybe a Skype call or something. Either way, many thanks to you!

Also, I found this somewhat helpful but it is based on a PC and therefore didn’t fully translate to my system. If anyone has a Mac version of these parameters please let me know.

The first thing to try is:
Whilst using Cubase as your Daw
load Kontakt-5.
Go to Options : Engine : Multiprocessor support (VST - Plugin)

Set this to off.

However - make sure in Cubase - Multi-Processor support is on
Devices: Device Setup : VST Audio System

I have the following options:
Audio Priority: Boost
Multi Processing : On
ASIO-Guard: On
Activate Steinberg Audio Power Scheme : On

If Cubase and Kontakt-5 both have Multi-processor support turned on - this causes drop-outs - and Peaks.
Let your Host sort out the Multiprocessor support out.

DDR-3 Memory
This is relatively inexpensive.
Max out your memory - it will help.

Your using an SSD.
If you can possibly afford it - Kontakt runs many times faster streaming data from SSD’s.

The combination of DDR memory, and SSD’s allows you to use Kontakt’s
Override Instruments Pre-load Size (K5: Options : Memory)
Double this to 120.

Then we go to Windows 7
Make sure your PC is optimized for Audio
System : System properties : Advanced : Performance : Settings
Set processor Scheduling for background services.

Virtual Memory
The more installed memory you have - the less you will need this (I turned it off - but suggest only try this if still having problems)
If you do need to use virtual memory - then make sure it’s addressing your SSD - and not your non-ssd drive. A 7200 drive is the slowest bottle-neck on your PC - a virtually useless idea for extra memory.

Don’t use over-clocking - it’s a false economy.
Win 7 will compensate by trying to park your as many cores as possible - to save power.
As it activates the redundant core - it has to transfer data - and that results in a cpu spike - exactly what you’re trying to avoid.

Having made all of these settings - re-boot

Big post!

I am all PC, so am probably limited in what I can add, but I notice a few things.

First, system latency? If this is set to very low, you will get instability. Better in general to work with greater latency where possible. I make mine low when playing in fast keyboard parts and Constrain Delay isn’t enough. But set latency high when mixing for better stability.

Audio set to boost?..I’d say not necessary as any half-decent computer will stream masses of audio on the standard setting - your system should be easily fast enough.

SSD? You could put libraries onto a super fast drive. But that shouldn’t be necessary. I have my systems set up with three regular active drives and a daily offline back up. That is: System / Audio / Data libraries and Backup. Nothing is bottlenecking

Also, I do limit memory a bit on hungry VSts such as BFD - I run 16 bit rather than 24

Some DAW users fall into the bad habit of assigning fresh reverbs etc to each channel as inserts…if that’s something you do, it will eat massively into your headroom. Better to configure reverbs as send effects

Same with instances of VSTs. If you have a multi ouput intrument, open one instance into the rack (F11) and assign MIDI channels. That’s way more efficient than loads of Instrument channels.

Finally, is your system - especially CPU running hot? If so, that will slow you down as most modern systems throttle down to protect CPUs. Last Winter, for example I purchased a ready made PC…it worked well until Spring and then seemed to get very noisy and very slow. I eventually realised that the CPU / fan vent arrangment was terribly badly thought out. I ducted in fresh air properly and that system goes like a bat out of hell now.

Sorry if these comments don’t apply or help, other people will no doubt chime in with useful ideas.

Best of luck


Not sure exactly what this means? Are your drives all on board or some external?

I think when I first installed Komplete 8 I may have dragged the individual instrument folders to my desktop for easier stand alone access. Could this cause a problem? Would i possibly benefit to reinstall and let it choose the appropriate location?

I have three internal S-ATA drives. The backup is external via USB3. This is mirrored in both systems.

I don’t think the location of the data would be a cause. Maybe not optimum, but not enough to wreck performance as you describe