Help with MIDI Learn Please

I have been trying to use MIDI learn with Cubase 12 PC. Specifically I want to control non cc parameters such as Cut off in Omnisphere using a bank of custom faders I own. See product here

I can get Omnisphere to assign controls in standalone mode to these faders, but not within Cubase.
For elemination purposes I tried loading Kontakt “Analog Dreams” and this will not work either. I therefore think this is a Cubase not recognising faders issue. I might point out that for control of CC values, (mod/ expression etc) these faders work.
I really have no clue as to how to do this. I have fumbled with

a] No Generic device
b] Creating a Remote Controller
c] Using the legacy Generic remoted
d] Using quick controls

I can get the sliders to be responding in set up dialogue in lower zone Remote Controller Setup, but I cannot get any VST instruments to respond. For Instance, in Omnisphere, right clicking on a cut off filter brings up MIDI Learn and a Green Box, but moving the physical slider does nothing.

Trawling the web brings attention to “Enable Host Automation” in right click Omnisphere, and user CC options in Omnisphere System controls. So far they do not seem to help

As you can probably tell by now, I am utterley clueless as to my solution or even direction of travel

Has anyone any idea of how to solve this please?

If you want to use Learn CC don’t assign that in generic remote or midi remote. Whatever is used by those is not passed through to your instrument.

1 Like

plus
Track Quick controls
and VST Quick controls

Cubase reserves any Midi signals that were used there
And when you try to assign any of them it will not work because it is reserved for another job

So make sure your Midi controller is not set up in MR / GR / TQC / VQC…

New Project
Studio Set up - no generic remote, no MIDI input for either Track or VST quick controls
Load Omnisphere
Right click a knob - select MIDI learn a green flashing box appears
This does not respond to my faders

Possible clue: After trying to set up a MIDI Remote again in Cubase (there was none in my postv above) I have noticed that in Cubase MIDI remote Editor the “Item Properties” for these faders is automatically set up for Fader 1 CC11, Fader 2 CC1 and Fader 3 CC7. This I think is a result of my previous use of these faders for CC allocation (for orchestration).
Is this conflicting, or should Cubase simply overide these allocations when using MIDI learn? Its non editable in Item properties.

thank you all thank you ANNAFREE for your persistence with this numbskull

Z

Slight Progress! Still in the dark!
I have actually managed to get one fader to respond!!!

Currently I have a MIDI controller set up in the lower zone and I have the first three QCs set to my three faders. The first QC shows "spec 8 " under the QC. I have no idea what this means but it appears to be a parameter for Omnisphere.
I then selected the right click menu for A knob in Omnisphere and istead of selecting “MIDI Learn”, I tried “Enable Host Automation” it worked!!! The first physical slider now responds to the virtual knob!
However. I have no clue as to how “Spec 8” arrived in the firt QC and the other QC’s are blank. If I try to allocate anything to them I get a list of over a thousand different controls with obscure names - spec 567, MIDI CC134:5 etc.
Right clicking and using "Pick for MIDI remote Mapping QC2… " brings up Cubase’s MIDI Mapping Assistant. This wants to allocate a CUBASE function to the fader, not an Omnisphere function

Still totally confuzzled. I thought MIDI learn is an easy one click thing!!!

Z