Help with midi out Dorico 5

Hi! Today i purchase Dorico 5 Update and my old Dorico 4 Projects can’t reproduce the midi out data. I use loopmidi to send the midi from dorico to reaper. I test to open the same template in Dorico 4 and everything is normal, but my template doesen’t work in Dorico 5. Dorico 5 don’t send any midi data when start playback, but when i play with my midi keyboard works. I think that it is something that has change in Dorico 5 that i cannot find.

Welcome to the Dorico forum.

In Preferences > Play, you might need to check “Enable MIDI thru”.

Thanks for your answer. It is enabled yet, but still the same.

Try disabling it, clicking Apply and closing Preferences, then re-enabling it. Sometimes that makes a difference.

I just did it, still the same :c

One other thing to try in Preferences is to do a “Reset to Factory”.

My keyboard is a MIDI controller keyboard and has no built-in sounds, so it can only be used for input. Someone else with more experience in using MIDI playback hopefully will be able to help you troubleshoot this problem.

Thanks for your help and your time! I just did it and still the same. I hope someone can help :c

One last thought, which is really only a wild guess on my part:

Open a Dorico project in Dorico 4, check that MIDI playback works, then go into Play mode and have a look under VST and MIDI to see what settings there are (if any) for MIDI instruments. Then close Dorico 4, wait for 5-10 seconds for the audio engine to quit completely, then open the project in Dorico 5 and do the same.

The dorico 4 and 5 playback template is the same. I try to create the same template from the start looking for a solution, but without success.

Hi @ARTYA , there is a bug in Dorico 5 in regards to MIDI out. We have a fix for it already and it will come out with the next maintenance update which is to be released pretty soon, so a little patience, please. Thank you very much.

5 Likes

Hi. I have this lack of MidiOut issue.
I’m running
Version 5.1.10.2081 (Jan 16 2024)
Dorico 5 AudioEngine Version 5.6.30.118

Is the bug above fixed at this level? If so, I’ll continue fiddling with my settings to try to get it to work.

Thanks.

This particular problem was fixed as described by Ulf in the Dorico 5.0.10 update that was released back then. If you’re still having problems, please provide some more details about the nature of the problem you’re experiencing.

Hi Daniel, I’m still on a very steep learning curve with Dorico but I’m happy to press on by myself at the moment in the knowledge that the best way to learn something is when you need to know it. If I get really stumped, I’ll come back but thanks anyway. Loads more settings to understand the function of yet and not to mention the ones on my Yamaha Clavinova (o:
Phaz