Help with MIDI Port Setup

Hi Guys,
I am dead in the water here! Your help would be appreciated.
I have not touched these settings for about 4 years and has stumped me and I can’t seem to work it out! :blush: :confused:

I have Cubase 7 on Windows 7 64-Bit which is a new system delivered and working for about 6 weeks until Win7 crashed (blue screen of death) and now I can’t get my control surface to respond.

If I go to Devices > Device Setup… and select MIDI Port Setup under Devices (top left) I can see a list of rows and columns. These are Yellow for the Windows MIDI In and blue for the Windows MIDI Out.
All columns are populated and read ok except the State rows for the MIDI Out. They read as Inactive This is the problem I’m sure of it. The crash must of some how reset them, I guess?!?!? :confused: This is shown here:
MIDIimage1.png
I may have to configure the Mackie Controls settings, what should I choose? This is shown here:
MIDIimage2.png
On the Transport, I can see the MIDI In fader flashing, so that seems ok?

After a whole day of going around in circles, I thought I would ask for some help :wink:

What am I missing?
What do I need to do to set the MIDI outputs to Active?

Thanks for reading

Control Surface: TASCAM US-2400
Audio Interface (MIDI I/O): TASCAM FW-1804

Did you carefully checked all the settings in the ‘MIDI device manager’ window ? Here, all my MIDI Out ports are indeed labelled as inactive in the ‘Device setup’ window, EXCEPTING the one that is used by already defined devices saved as .xml files in the ‘MIDI device manager’ one. Maybe something is not set here as it should…

Hi Cubic13,
You’re correct in your assumption, there is nothing set there! The MIDI Device Manager is empty! :astonished:
Do I have to re-install the US-2400 driver?

…since the system was working then stopped after the crash, as I mentioned, would the MIDI file(s) or the .XML file still be available on the Hard disk? If so, where can I find these files?

Could I then import them again?

If you still have the .xml file available, just use the ‘Import setup’ button in the ‘MIDI device manager’ window and open it. this should make any MIDI out port defined in it available.

About where it is located, I can’t be sure. All depends on where you saved it previously. I mean, the .xml MDI device files are not part of the preferences or any other Cubase pre-defined location.

And no, the US-2400 should not have to be installed again : it’s a different thing and, as it appears in the ‘Device setup…’ window, it is already taken into account by Cubase. Simply, the latter doesn’t know what to do with it as there is no port usable for it at the present state…

This is one of the problems of having a system built for you. There is no record of where the .XML files are (if any). The system builders have not been forthcoming with any help so I’m forced to do it myself. :imp:

Anyway, I have moved a little closer to getting it fixed. From my images you can see the dropdowns for the MIDI input and MIDI output. It appears that if you match the entries MIDIIN2 (US2400) with MIDIOUT2 (US2400) not shown, and MIDIIN3 with MIDIOUT3 etc I can get faders to move and pan pots and the transport control to respond which is great! However, I can’t get the Audio track and Fader to match. For example Audio 01 in Cubase will map to Fader 17 Audio 2 to Fader 18 and so on. Then by the time I get to Audio track 33 I get nothing. There’s a missing Fader range from 1 to 16. I just can’t work it out at the moment. I using trial and error.

What about using the Windows 7 Restore point??? Would that help??? :confused:

Let’s start trying to fix things Cubase-Remote controller related first, before a hit or miss solution such as a Windows restore point recall. Honestly, I don’t rely on it : IMO, it’s just a desperate last solution when everything else failed…

What I don’t get is all the Remote devices that you have defined in your ‘Device setup…’ window. If you use, as logical, a Mackie Control predefined for each port (4, if I read correctly the US-2400 manual), what is the need to have 5 of them (3 Mackie and 2 generic remotes ones) ?

I mean, the simpler, the better. First, stick just on one device for each port used and get rid of all the others (but carefully export them first, just in case…). As the US-2400 is designed to allow a Mackie Control emulation, keep these devices first if there really is the need and see if you can adjust the different controls to what you are expecting in each of them : it’s tedious but worth doing so. Just an advice about this : make sure that ALL the US-2400 controls are defined in your devices and ONLY these. And avoid at any cost conflicts between devices : one port, one device is the rule.

And if you see that the Mackie Controls don’t allow you to do so, then I’m afraid that you are for Generic remote definitions instead. Worth doing so, believe me, but I admit that I don’t have your problem, having to use MIDI out ports, as my two generic remote control devices don’t have motorized faders.

Then comes the MIDI device problem : the three I have defined here are only for synths, not for a remote controller that has a bidirectional connection to my DAW. I’m afraid that you are here also for a complete MIDI devices definition which is also tedious, as there seems to be only Yamaha equivalents in the Cubase list of them and these are more mixer devices than remote ones, actually…

So, there are two stages :

  • First, define one and only one device for each port used in the ‘Device setup’ window, with all US-2400 controls and only these in it,
  • Second, define the MIDI devices needed in the ‘MIDI device manager’. At this stage, I guess that you’ll have to define also four of them.

Tha task is complicated by the fact that there is apparently nothing in the manual about how to set your US-2400 with Cubase. Using the other hosts chapters could give you hints about how things should be set, though.

Good luck and keep us informed about things are going…

EDIT - See here : http://tascam.com/content/downloads/products/315/US2400%20FAQ.pdf to set the US-2400 in more or less compatible mode with Cubase (at least previous versions).

Cubic13… thanks :slight_smile:
I’ll need a little time to digest your reply… :blush:
In the meantime, this is what I have done. I have now six Mackie Control emulations :blush: and I was beginning to think this isn’t right! I’ll do as you suggest.
I have done a little bit of digging on the internet and general reading of the documents. It seems that my MIDI port mappings are missing or corrupt (as we know). What role does the MIDI Device Manager play in this? It is empty.
I get a large list of MIDI device scripts when I click on Install Device…of course the US-2400 is not there! lol Is this what I have to build/generate?

BTW with my 6 mackie emulations, I pulled up a previous project… and all the faders and pans all moved into position! Wow! I can play the project, stop start, FF, Rew… What’s going on there? :confused: It was encouraging at first but when I tried to create a new project with one audio track - Audio 01 it didn’t map to any fader. :cry: So, I did, right-click Add New track x23. Only the last 8 audio tracks mapped to Port 1 (the first 8 faders).

True!!! :blush:

Well… in image 2, the menu options are what I found while searching around. I guess it is the setup from the builders. Since there were six entries I just added the appropriate amount! :slight_smile:

Agreed!

Hhmmm… where do I look for this? Is this the MIDI Device Manager dialogue? If so, it is empty!

I start again in the morning… :wink:

Thanks Cubic13

Indeed…

The MIDI device manager takes care of all what is supposed to be used as a MIDI external devices controlled by Cubase : it makes all messages transmitted by Cubase comprehensible by them, in order to make communications between the two possible.

To sum all this up, let’s take an example : I have 2 generic remote devices defined in the ‘Device setup…’ window. These are corresponding to the 2 devices I use to control remotely Cubase (the VMK-188+ keyboard and the MPD-32 pad controller) : each of them has its own MIDI input port, without any MIDI output port defined. In your case, this is where I’m not sure of : I don’t know how the MIDI output port parameter acts, considering the parameters definable in this window… But, as none of my remote devices is motorized, I didn’t have to define neither a MIDI out port in the ‘Device setup…’ window, nor a MIDI device for each of them in the ‘MIDI device manager’ one, as they don’t receive any message from Cubase.

OTOH, I have 3 MIDI devices defined, one for each of my external synths : these are required so that Cubase could send the appropriate program/bank changes for them when I select a preset in the ‘Program selector’ of each of the dedicated MIDI tracks used for them.

The problem that we have in your case is that there is a bidirectional communication, hence the need to define BOTH remote devices in the ‘Device setup…’ window AND MIDI devices in the ‘MIDI Device manager’ one… But again, as I have no experience of bidirectional communication between Cubase and external devices, I only guess that it works that way…

Exactly, and this is where the true problem begins. As you don’t have any .xml definition file left, you’ll have to generate new ones from scratch.

_Transport functions such as stop/Start/FF/Rew are rather basic ones : no surprise. OTOH, what is surprising me is that all the faders and pans moved into position on the US-2400. Problem is that, again, I don’t have any experience using motorized remote devices but, as there is no MIDI device defined, i’m wondering how could something like this happen. I have no explanation, here. Perhaps someone with some experience could chime in…
_

Again, I think that you have a crippled setup. There are 4 MIDI In and Out ports from your US-2400 unit : you should have 4 remote devices in your ‘Device setup’ window as well as 4 MIDI devices in the ‘MIDI device manager’ one.

Again, it’s the thing I don’t get : why 6 entries as the US-2400 provides only 4 different ports ?

No, in the ‘Device setup…’ one. The ‘MIDI device…’ is empty because there is no defined MIDI device defined in it, yet. In the former one, check that every single device remaining has different MIDI Input and output ports.

This is what I did today:
First off I would like to thank Cubic13 for his support and willingness to help. :wink: :sunglasses:

I have included all these steps to help anyone else that may be faced with the same of similar MIDI Port problems

  • 1. Re-installed the driver for my FW-1804 audio and MIDI interface. Just to be sure that no corruption has taken place.
    2. Reboot

No notable difference. The same menu options are there. See Image 1 and 2. Moving on…

  • 3. Checked that the US-2400 is in Steinberg mode (Aux 5 flashes at turn on)
    4. From the US-2400 manual, the US-2400 has 4 ports, from left-to-right Port 1 (8 faders + transport and others) Port 2 (8 faders) Port 3 (8 faders) Port 4 for joystick (surround sound). So, we don’t need MIDI Port 4. Nothing in the manual for Cubase, other DAWs but no Cubase.
    5. From the Cubase Remote Control Devices (RCD) manual that came with the Cubase installation, I chose to emulate the Mackie Controller (and I remember this working on my Win XP system). This looks like to do everything I need (or used to do) because the Mackie control has motorised, touch sensitive faders. So, no need to concern ourselves any further about motorised faders, they’ll all taken care of. Touch sensitive means that if you touch them, the motors are overridden. Mackie Control emulation is the way to go, the RCD manual confirms this. No need for Generic Remotes. :wink:
    6. From the RCD manual page 20 (Devices > Device Setup)…In the Devices list, the top-most device represents the right-most channels and vice versa… Andmake sure that the used MIDI ports are deactivated in the “All MIDI Inputs” device. Important point that last one, you will need to select the MIDI Port Setup under the MIDI folder. The column is present there. Essentially, it stops duplicate channels.
    7. So, add 3 Mackie controls. These are automatically numbered from top-to-bottom Mackie Control, Mackie Control 2 and Mackie Control 3. The left-most bank of 8 faders on the US-2400 is MIDI Port 1, therefore, choose Mackie control 3 select MIDIIN3/MIDIOUT3 from the dropdowns (in my case).

Now we need to test what we’ve done. Load up an empty Cubase project

  • 8. Add a single audio track and make sure Fader 1 responds. Check the other 7 in the same manner. If all correct, then deactivate in All MIDI Inputs column for this Port; uncheck the box.
    9. Next choose Mackie Control 2 and complete the same procedure but using (in my case) MIDIIN2/MIDIOUT2. Test by adding more audio tracks.

Now we should have 16 responsive Faders.

  • 10. Finally, choose the last Mackie Control (top of the list) using the same principles above.

BOOYA!
:smiley: :laughing: :smiley:

Thanks Fuzzbox.
It works with Nuendo6 as well.
Much appreciated.
Cheers

You’re welcome. I’m glad it was useful to you. :sunglasses: