Help: Yamaha WX-5 midi wind controller plays out of tune...

Since the Cubasis 1.8 update (great update, BTW!) , my Yamaha WX-5 midi wind controller is playing out of tune.

I’ve been using Cubasis as a tone generator for quite a while now. (I also use Cubasis a ton for sequencing tracks :smiley: ) I usually use the muted trumpet, piano, trombone, or guitar sounds. The response time is great , very little to no latency, and the sounds feel very realistic to play with my wind controller.

I’m guessing that I’m inadvertently hitting the pitch wheel by my right thumb that is on the WX-5 and that pitch signal is being sent to Cubasis but not being undone when the wheel is released.

Can anyone on the forum and/or the Cubasis Help/Support please help me out to change any setting needed so that I can stop this from happening?

Ideally, I’d like Cubasis to still respond to the WX-5 pitch wheel, but return the pitch to the original level when the wheel is released, which is how things were working before.

EDIT: Title changed…


Anyone having a similar problem in Cubasis w/ any your midi input devices( keyboards, midi trumpets, etc…) that have pitch wheels on them?

Hi dj8,

Pitch Bend works here as expected with Midimann II and Motif ES8.
Please have a look into your CC controller lane inside the midi tracks.
Maybe you have recorded some " Pitch Bend " controller data and that’s the reason
why your WX-5 controller works detuned in cubasis 1.8 and not in cubasis 1.7.

Cubasis 1.7 can’t read available CC controller data.

If your detuned WX-5 is caused by an other issue, please send us an detailed step by step description.

best jan

Are you sure your WX5 switches are set correctly? You probably already know a lot of the switches effect pitch bend. For example, I normally turn 2-7 on and leave 2-8 off. If your WX5 sounds OK through other software or hardware (eg VL70-m), maybe you have pitch bend response set wrong in Cubasis (assuming there’s a setting in there somewhere).

Thanks for both of your replies. Sorry for the delayed response. I double checked… I didn’t have any midi tracks drawn in… But, I even drew in a midi track and checked for CC data for pitch bend: nothing there.

The only fix I’ve come up with is to open the Microsonic screen (usually using the muted trumpet patch), tapping the “E” in the bottom right, and setting pitch bend range to 1… This does fix the problem.

I would like the ability to still use pitch bending… Will play with the pitch bend range values some to see if there is some leeway.

To Cubasis staff: just restating that this problem didn’t start up until latest 1.8 update…


Just to be clear, I’m aware of the switches on the WX5, it’s definitely not them… WX5 works fine with other apps and Logic… Thanks for your reply!

Hi dj8,

Sorry, it’s not reproducible here.
Please create a new project, with one midi track and assign Micrologue as instrument
Record some midi notes.
Compare the internal cubasis keyboard with the WX5 controller.
If the WX5 controller is detuned and the internal keyboard not, save the project and send it to us.



I tried adding a Midi track w/ Micrologue assigned (using IAA). That plays perfectly in tune.

I left the track and added a 2nd MIDI track using the internal piano sound. When the pitch bend range is wide (approaching 12), I’m still getting “stuck” detuning, but not as bad as before. Strange… Will try some more and send you the file.

Also, I should probably ask this in another thread, but, please, please, please, add an acoustic bass (i.e., jazz bass) sound to the built in collection. :smiley: It is sorely needed. As is, I have to waste resources using IAA to SampleTank, etc. every time I want to use an acoustic bass sound in a project.