Help! Yeti USB Mic, FAIL! Cubase Elements 8

Ok, so I’ve been messing with this USB Yeti mic on Cubase 8 for a SOLID 5 minutes (this is a joke, I’ve spent days), and well, I’m ready to pull my hair out. I can’t get it to work. When I get the mic to actually appear to be sending sounds to cubase I play it back and no matter what I do I don’t hear anything, and when I select built in stereo I can’t find my yeti anywhere. I’m going CRAZY. Well, I set up the ASIO device for the yeti mic and it picks up the mic, and it shows that noise is being “recorded” but it never plays back, even if I switch back to my built in audio. Also, I was kidding about the 5 minutes, that would be ridiculous. Working on OS Yosemite Macbook pro.

Can nobody help me?

Not without a lot more information and clarity on your set-up.

Ok, fair enough. My setup is pretty basic. I’m using MacBook Pro (13-inch, Mid 2009),2.26 GHz Intel Core 2 Duo, 2 GB 1067 MHz DDR3, NVIDIA GeForce 9400M 256 MB. I’m only running Cubase Elements 8. I know my mac needs updating, which I’m in the process of getting a new Mac. But that’s pretty much it. Just a USB mic, Cubase Elements 8, and this computer. Running OS X Yosemite 10.10. 1.

All I want to do is be able to record audio through my mic. I’ve tried everything. I set the ASIO to my Yeti, but then I can only hear through my mic, and when I don’t have ASIO set to Yeti, the mic doesn’t show up anywhere (that I’m aware of).

Hi there

You may already know this but here goes anyway. You have to monitor through the Yeti, that is, record through the Yeti and use the Yeti’s headphone out for monitoring, ASIO can only use one hardware item at a time for input and output, in this case the Yeti. If you knew this, sorry for wasting your time.

Best Regards

Dave

Dave, advice is never a waste of time! Thank you very much for your response. I kind of got that idea, but it’s not outputting when I try to play it back…I see that sound appears to be being recorded, but nothing I try will let me hear what I recorded.

Not sure if this will help but it might…

https://www.steinberg.net/forums/viewtopic.php?t=8824#p59152

Do you have the Monitor button on the track enabled? It looks like a little speaker.
It should be disabled if you want to hear the recorded material. Enabled if you want to monitor the microphone.

Lol, I had just looked on here to see if anyone had responded earlier and nobody had, and I started messing with it and I was like “well hell maybe this monitor button is doing it” and then BOOM! It worked, and I came here to say I had figured it out. That’s crazy that when I came on here that’s the suggestion you gave me, it’s like my ear’s were itching lol. Thanks man!

Man, so many small details to learn that could hold up a project for days,hours,minutes for some small dumb button. Sheesh, I got a lot to learn lol.

Good to see you got it sorted.
Yeah, I have just switched from Reaper and it’s taking me a while to get used to where things are, keyboard commands and how to do things. Things that seemed obvious for me in Reaper can take a while to figure out.
I’m trying to record a couple of dummy projects at the moment just to learn where all the tools are and how they work.