Hidden On-Screen-Keyboard status can cause trouble in 13

Whenever I tried SHIFT+DELETE, this did not remove the selected track.

It worked from the context menu, but not with the keyboard shortcut. I re-assigned the command, but still it wouldn’t remove the track.

Then I tried another track command ALT-D to duplicate a track and got an error message telling me the onscreen keyboard filtered the key command. But I saw no onscreen keyboard open. What the heck was going on here?


I had to toggle the onscreen keyboard on and off to get the keyboard shortcuts back to working as expected.

Same here!


Did you use the on-screen keyboard in the MediaBay window or MediaBay Rack previously? In other words, was an Instrument Track preset the last one, you had in the MediaBay/MediaBay Rack listed (so the on-screen keyboard was present)?


I don’t remember having seen it there before, and there definitely was no on-screen keyboard visible at all, when I ran into the problem. But I am not absolutely sure when and where I last time used an on-screen keyboard in Cubase 12 pro last time.

Either way, I think the status of the on-screen keyboard should not be a well kept mystery somewhere deep within Cubase. It should be possible to disable it globally (without any need to go through various screens where it might have been used), and probably there should also be a clear status feedback/symbol to see if it is active anywhere in the system.

In my case there was ZERO optical feedback of an active on-screen keyboard in a new project with right zone media bay open (VSTis or VST Fx), while the shortcuts would not work. This scenario should simply be impossible, no matter when and where any on-screen keyboard might have been used before.


Just to clarify, I mean this Keyboard (see the screenshot, please).

Screenshot 2023-11-07 at 13.46.53

Unfortunately, if this is the last preset you select in MediaBay (Rack), even if you close the MediaBay (Rack/Window) the Key Commands are still blocked by the MediaBay’s on-screen keyboard. The solution is either:

  • Open MediaBay and select any other preset (for example an Audio loop). Or…
  • Disable the Computer Keyboard Input in the MediaBay (window or Rack).

Yes, but there’s lots of sub-entries and even sub-sub entries in the media bay, as I described. Presets and User-Presets have 5-6 sub-directories each, so if you go into user presets, you get

  • 6 sub directories
  • going into the first (track presets) gives you 5 more sub-sub directories
  • so you have to go down one more directory to even find your last used on-screen keyboard.

Now to assume that you are aware of having had such an on-screen keyboard active for any reason anywhere buried there at some point in time, having to use one of the workarounds you describe (or the one I found for myself) does not look like a practical or even acceptable form of UI design to me.

From my view there should - if not by default - at least be a preference setting allowing you to have computer keyboard use reset to normal (meaning no on-screen keyboard) automatically, in the very moment you leave the sub-directory, where you used the on-screen keyboard.

There probably will be very few users who would like to keep the on-board keyboard setting in place and use the workarounds decribed when returning to recording and editing. I for one do not want the on-board keyboard setting which I may have used to get in my way, not for a single second, after I left that sub-sub-directory.


The MediaBay’s on-screen keyboard is present anytime, you select the Instrument preset.

Probably the easier way is to disable the Computer Keyboard Input in the MediaBay (window or Rack).

But if it is never buried in the subdirectories, it was definitely not visible while I ran into the problem.

1 Like