"Hide All Automation" does weird, annoying stuff

In this track, I’m using 3 drum machines- one for verse, one for CH, one for bridge - and one Groove Agent. All of them use sub outputs. This leads to a metric crapload of tracks cluttering the screen. Luckily, I rarely need to see any of them, so I have them all tucked away to save space and maintain sanity.

But, every freaking time I edit some automation and then go to hide the lanes that are now unnecessary to see, I hit my “Hide All Automation” KB shortcut Shift A and my location in the track stack jumps + every freaking sub output in my session is displayed. This has turned that KB shortcut into an “immediately get lost in your session and start shouting curse words while you minimize these sub outs for the umpteenth time” button.

Usually, automation-related KB shortcuts keep the currently selected track centered in your project window so you don’t get lost. However, it seems that Hide All Automation is unfurling those sub outs AFTER it centers your view on the selected track causeing your location in the track stack to jump almost randomly and leaving you with this “where the hell am I, what the hell just happened” feeling.

Also, Hide All Automation seems to be doing something in addition to what’s described on the label. I would love to describe what’s going on, but I don’t really understand what I’m seeing. ezgif.com-gif-maker

All I’m doing is hitting Shift A there - that’s my shortcut for Hide All Automation. If you find what’s going on hard to follow, yeah. Same. In addition to the track-stack location jumping (mercifully, not very much this time), it looks like the selected automation lane on the Drum Kit master out is being toggled between “volume” and “pattern select” for some reason. And actually, on a different set of master/subs above, the R/W automation buttons are darkened out in one of these Shift A states. I’ve never seen that before, and I don’t even know what that could mean in this context.

Is there a way to stop all this? It’s driving me nuts.

Hi,
I would like this to be tagged as issue or filed as a bugreport, because hide and show automation commands are completely messed up with sub outputs.

I experience the same behaviour. The “Show Used Automation” hides all sub output tracks, while “Hide All Automation” shows all of them regardless of what their state was before.

Also, annoyingly, “Hide All Automation” (the one that shows all lanes) toggles the automation parameter of the first sub output lane between volume and mute. So even if arguably maybe sub outs aren’t technically automation lanes and therefore cubase puts them away when automation is shown, that can’t be correct behaviour.

Anyone else experience this too?