"Hide empty staves" does not work

I want to hide empty staves in piano part. I did everything according to the manual, but it does not work. What am I doing wrong? Is there a video on YouTube that explains it?
Thanks!

Did you add piano as a section player or a solo player? That’s important.

Check this thread: https://www.steinberg.net/forums/viewtopic.php?f=246&t=103595

Did you definitely select the piano layout in the left pane of Layout Options?

Do you have chord symbols set to appear between grand staffs?

Is this a MusicXML import? If so, the first clef in the lower stave is probably an explicit one. Select it and delete it.

When I open a new clean project and add the piano as a solo player, “hide empty state” works. But when I open the project BIGBAND from template, this feature does not work.

Yet if I start a new project from the Big Band template it works absolutely fine. Do your settings definitely look like this?

Sorry. I only looked at Full Score. In the part is stave hidden.

In the attached file I want to hide the empty staff in system.
Nothing happens when I run System -> Hide Empty Staves.
I tried some of the things here but no success.
Any idea why Hide Empty Staves is not working?
The file did start out as a midi file import krogerfeedback survey.

Have another go. You haven’t attached anything. (You need to zip Dorico projects before uploading)

…and welcome to the forum!

Ah yes, that too! Sorry, I’m on an iPhone and the mobile view of this forum doesn’t show users’ post counts etc.

Rotate to landscape mode… I just learned this.

Thanks for reminding me, Dan!

Also if you’re viewing on a mobile device, you can change the default skin to one that works better on mobile. Click on your username at the top then Board Preferences and set Board Style to ‘subsilver’. This produces a more compact view where things don’t scroll off to the side.

Dear Paul,
That’s the setting I have on my forum setting, and my iPhone (safari) does not show me a poster’s count…

Why is my piano stave not hidden?
1.png
Although I got all preferences right I think:



Thanx for helping.

Given your piano staves are joined by a brace rather than a bracket, I can’t trust that anything in this project is “default”.

You might have hidden stuff, or it might be that manual brace, or it might be you have an explicit clef at bar 1. If you want a definitive answer quickly, post a cut-down version of the project, not a screenshot.

Here it is.
Thanx a lot
CutDown.dorico.zip (842 KB)

I changed the brace back, replaced the clef again with a treble clef, removed all other information - nothing…still there. When I remove the music from both staves completely, it works. Otherwise not.

This setting prevents Dorico from hiding staves of grand staff instruments:

You also have an explicit bass clef at the start of the first bar of the top piano stave. You’ll need to introduce that wherever you want that stave to appear, rather than at bar 1.

You are a genius. Thanx a lot ! It is the chord position between staves…if I change it, everything works fine…so there is no way to have chord symbols between staves and hide the upper piano-staff?
That’s a pity…