Hide empty staves no longer worked after some manipulation

A problem I often have: Hide empty staves no longer worked after somme manipulation like tranpose, delete a system track… and to revert with Ctrl + Z doesn’t bring the state before!!!
Exemple:
transpose:
hide_empty_tranpose

delete a system track :
hide_staves_delete

I just put a project with non musical things to show the problem I have
hide empty satves.dorico (1.2 MB)

EDIT: I thinks it’s a bug?!: the hide empty staves is not refresh !
I must always do something like that: never-> apply then allways-> apply

I’m noticing this in a project at the moment. It seems to be to do with the presence of chord symbols - sometimes Dorico incorrectly hides staves that do contain visible chord symbols (only), and sometimes hiding all of those chord symbols doesn’t prompt Dorico to hide those staves.

I’d be happy to share a project with the team, privately, if they’d find that useful.

@pianoleo
Thanks for the reply.
I finally write a script(macro) because to often to do it manually, when you change a little thing in the score


What is the code to put put at the end of the script to close automatically the windows and return to the sheet:

Somthing like: does it exist
app:doCommand([[Project.Layout.Options, close]])

I get this issue very frequently, in about 60% of my scores. When it starts happening, every single change to the score (in write or engrave mode) will unhide empty staves.

The only workaround I’ve come up with is what Dup suggested: select Never, then Apply, then select Always, then Apply again.

I’m on Dorico SE, so I can’t even use macros.

Even though there is a workaround, the issue happens so frequently (with every single edit), using the workaround ends up taking a significant amount of my work time.

I can confirm that whenever this does happen, it’s in a score where the affected bars have chord symbols.

Welcome to the forum, @Aki_Kanerva. I’d be interested to see a project of yours where you experience this problem. Please attach it here, together with details of how to reproduce the problem, and we can take a look.

Hi @dspreadbury and thanks!

Here’s an example project made in Dorico Elements 5.1.30.2109 (sorry, in my previous message, I mean Elements, not SE).

To reproduce the issue:

  1. Open the attached project
  2. Enter Write mode
  3. Insert any note anywhere in Write mode

OR

  1. Enter Engrave mode
  2. Add a system break anywhere

Observed result: Hidden staves become visible.
Expected result: Hidden staves should remain hidden.

  1. Perform an Undo

Observed result: The staves that became visible remain visible.
Expected result: The staves that became visible should go back to their previous state of being hidden.

Mike Oldfield - Moonlight Shadow.dorico (930.4 KB)