Hide Empty Staves


Apologies if this has been asked before, I did do a search but with all the searches I tried, I couldn’t find an answer to this specific question…

I’m trying to hide staves of a multi staff instrument for a score. This score is just for me, never to be read by anybody intelligent!

I want to hide all staves that are empty. However, on the first system, there is always one staff of each multi-staff instrument showing. Whereas if I uncheck ‘allow single staves of multi-staff instruments to be hidden’ it hides them completely on the first system but then shows the empty (ie either RH or LH of a piano/keys part) ones in all the other systems…

Is there a way to hide them both in the first system and in subsequent systems if one or other of the multi-staves is empty.

Hope this makes some sort of sense, it seems to be much more complicated to describe than it should…

Cheers in advance,


There must be something in those staves, or they would hide.

Is it an XML import? Any hidden elements? Explicit bar lines?

Hi Dan,

I’ve tried selecting all the empty staves in the Full score in write mode and pressing delet and they don’t go away! It’s a file created from scratch in Dorico.

Let me upload some pics to show you what I mean…

What I want, is the first system of the first pic with the subsequent systems from the 2nd…

Is that possible?

Cheers as always for the help.


Sorry, 1st pic should read ‘allow multi staves…’ UNchecked


At rehearsal B, is that boxed text attached to the lower staff?

Hi Dan,

All the text is system text…


“Rock Pno” isn’t system text.

I’m just guessing. I’d need to see the project file.

No, you’re right, the ‘Rock piano’ isn’t system text, but that’s attached at the beggining of the bar that it relates to…

If there was anything in the bars at the beginning, why does it hide them when ‘hide empty staves of multistave isntruments;’ is unchechecked, in the first system but not when it’s checked?

That’s the bit I don’t understand…


Have you tried deleting the clefs? Some XML adds a ‘new’ clef.

It wasn’t an XML, but a new project.

Please attach the project itself if you’d like further help. It’ll save time in the long run.