Hide Instrument Change text

To get round the problem of the Halion Tuba not playing the bottom notes, I’ve made a part with a second GM tuba to reach the low D.
Problem is, instrument changes now show in the score. Like this…


Is there any way to hide this, both in score and in parts. I looked in Engraving Options --> Instrument Changes, but a hide option is not given.
Any ideas, anyone?

Rename the second instrument to be “blank” (just a spacebar).

Actually, probably safer to rename just the short name as an invisible space. Then in Layout Options—Players, show short names at instrument changes.

You can’t natively hide instrument changes completely, which is understandable.

Thanks, Dan. But I can’t actually find a way to rename (or unname) the two tubas. Clicking on them, or right-clicking–>Rename, only allows me to edit the name of the tuba group.


Is there a way to edit the names of tubas 1 & 2 that I’m missing?

Click on the name, and you’ll find an option for “edit name.”

You need to click on the name of the instrument, not the name of the player. The instrument card is inside the player. The picture you posted shows that you are renaming the player.

Thanks, Dan, but I’m still not getting this. There is a player “Tuba” who has two instruments “Tuba 1” and “Tuba 2”. That’s what I see (cf my attached graphic above).
The problem is that when I do right-click–>Rename on either of the two instruments, it takes me direct to editing the player name. There does not seem to be any way to edit the instrument name.
???

You can do this in Engrave mode by selecting the instrument change label and overriding its text in Properties.

Daniel’s recommendation avoids the workaround, but you still ought also to figure out to edit instrument names.

Click on the player… then hover over the instrument name card and click the arrow to expand. That’ll bring up “Edit name.”

Dear Daniel, Many thanks indeed. That has mostly worked (but see below). Btw, it’s wonderful how the chief designer of the entire programme takes time to answer qs like you do. May I beg one more question then I’ll stop bothering, at least for today.
Like I said your suggestion above worked for all the instrument changes, except one. For some strange reason, this instrument change (unlike the others) has got the legend “To Tba”, and the “To” doesn’t hide.



How can I hide this “To”?
.

Thanks to Dan for his really helpful reply. Still wondering if anyone can answer the question above, nominally directed to Daniel?

Try switching on the ‘Hide prefix’ property as well as setting the ‘Custom text’ property to an empty string.

I hope that it’s ok to answer to this topic from 2 years ago. I have a further question about it.

If I want to hide an instrument change label I select it and override its text in the properties as Daniel suggested. This way I don’t get a signpost like in other cases (hiding tuplets for example) because I only hit space one time in the property “custom text”. Is there a possibility to get this instrument label back if I change my mind later? I don’t see a possibility to select it because there is nothing I can click on.

Are there maybe other possibilities to hide instrument change text in the current version?

Thanks!

Yes, unfortunately if you hide an instrument change label in this way, it’s very hard to bring it back because we do not at present show signposts for empty instrument change labels. We hope to improve this in a future version.

2 Likes

Try dragging a marquee selection above the first bar of rests (where the instrument change would be if it was visible!) and you should find that the instrument change’s properties appear again in the bottom panel.

If there’s a visible key change (which there won’t be if you’re fooling Dorico into using two different tubas), then select that and go Edit > Reset Design. That will (sometimes) bring back instrument change labels.

1 Like

Thanks, Leo! Works fine with the marquee selection! :smiley:

I also wanted to try out your tip with the key change. But I didn’t find “Reset Design” in the Edit Menü. I tried “Reset Appearance” but that didn’t work so I think you mean something else. Could you please explain that I can try it out? Many thanks for your help!

D’oh. Even after four years with Dorico, I still forget that it’s Reset Appearance and Reset Position. Apologies for my Sibelius hangover!

No Problem, Leo! I thought I have overlooked something :smiley:

I tried “Reset Appearance” but in my example it didn’t work. Maybe in other cases. But as you have written: “sometimes”.

Thanks!

If you select the key change, do you see some different Instrument Change Key Signature properties show up? If so, try switching the first one on and see if the instrument change label reappears. Again, I know I’ve seen this work in the past but I’ve never found any rhyme or reason as to why it sometimes works and sometimes doesn’t.

I see 3 Key Signature properties in engrave mode. Do you mean these properties? I switched the first one on but the instrument change label doesn’t reappear. But I’m not sure if you mean this property.

But your tip with the marquee selection works fine. Just wanted to try out your other solution :smiley: Many thanks for your help!

I did indeed mean the first one of those properties. Again, sometimes it doesn’t seem to work!

1 Like

Thanks, @pianoleo , for your short video and taking the time to create it!

@dspreadbury : In addition to the feature request for the possibility to hide instrument change labels in future updates would it also be an idea to have an option in layout options to choose if you want the instrument change warning for a certain instrument or not? I think of Percussion Parts where I don’t want these warnings when I have a lot of percussion instrument changes in a score and only would like to have one indication while I want both indications to be shown in for example wind parts. It would be great to have an option like that in the future!

1 Like