Hide player labels in part

Greetings all,
i have a divisi change at a system break in the score. This makes the labels a couple of bars too early in the part. How can I hide the player labels here? No matter what I select in the divisi change they remain visible.
Clearly I’m missing something.

You can select the player labels in engrave mode and hide them from the properties panel.

thanks, John
but there’s no hide property when I select them in engrave. All I can do is create blank text in the ‘custom text’ field. Doesn’t seem like the intended method.

Hopefully using blank text is an acceptable workaround for you.

On further reflection, here are two other possibilities. What if you go to Layout Options>Staves and Systems and uncheck the option “Show divisi change labels above staves” for the part layout? Or what if you simply make the divisi change happen a couple of bars later?

I appreciate the follow-up.
I want the labels to show in general, just they are sometimes in the wrong spot due to system breaks in the score. There is a lot of divisi so I had a lot to consider when laying out the score and I can’t (or don’t want to) move them. It would be nice if someday we could move divisi changes independently in the part. For now I just used the blank text workaround from a few messages back. then added the labels with shift-x text where I wanted them. The only drawback is the text hides without any signpost.
I do still wonder, though, why I have the option of hiding the labels in the divisi change window when it doesn’t appear to do anything.
Thanks again for the suggestions!