Hiding bar numbers at rehearsal marks

Hi. Getting to grips with Dorico slowly - lots of “unlearning” to do, as well as learning new things. Loving the approach - just will take a while until I “think” in Dorico rather than “thinking” in Sibelius then translating that into Dorico!

When showing bar numbers every bar, with the “Hide bar numbers at rehearsal marks” option switched on, I’m still seeing a bar number at a rehearsal mark if that starts a new system. Is that the intended behaviour, and if so, how can it be over-ridden? I’ve tried selecting the errant bar number (just the number) and deleting it, but that doesn’t seem to work.

Thanks for any help in advance.
Screenshot 2016-11-19 10.52.30.png

It is the intended behaviour as things stand; I believe the bar number would not appear if you had bar numbers set to appear at the start of every system, but if bar numbers are set to appear every bar, then the program won’t hide them when they coincide with a rehearsal mark at the start of a system. We should be able to address this in a future update.

Daniel, just to clarify: selecting in Layout options Bar Numbers>Show Bar Numbers>Every system and tick on “Hide bar numbers at rehearsal marks” also results in a double numbering in those instances where the layout places a rehearsal mark at the beginning of a system. I wonder if Dorico could allow another option: “Hide bar numbers at rehearsal marks at beginning of systems”, which would hide bar numbers in these instances, or simply have “Hide bar numbers at rehearsal marks” be the overriding effect no matter how the music gets casted off.
barnumbers.png

We thought it would be OK to show the bar number at the start of the system if it wouldn’t actually bump into the rehearsal mark, and indeed I think this is the right call if your rehearsal marks are not duplicating the bar number, but I can certainly understand that if you are using bar numbers as your rehearsal mark sequence type, you don’t want the bar number to be duplicated at the start of the system both as a bar number and as a rehearsal mark. We should be able to add an additional check for this situation in the next update.

An option to suppress bar numbers at any rehearsal mark would be good. I often have something like a large mark, a timecode box, a section title and cues - any tiny saving of space is worthwhile.

Dorico will already suppress bar numbers at rehearsal marks if you switch on the option found on the Bar Numbers page of Layout Options.

Hi Daniel,
I’m editing some orchestral parts at the moment, typed off a score which uses big bar numbers as rehearsal marks. I have to manually drag the bar number out of the page every time the rehearsal mark is at the beginning of the system. Any chance you could look into this again and maybe put it on the list for the next Dorico update?
Thanks!
AHonegger

Is this what you are looking for, or were you dragging the Reh Mark bar number off the page?
Did you want bar numbers and Reh Mark showing when the Reh Mark is not at the start of the system?

This is basically what Daniel said.

Hi Derrek,
that box is not ticked in my project, yet when there is a rehearsal mark at the start of the system, the bar numbers show up anyway so I have to drag them manually out of the page in order to hide them. Daniel mentioned that “they thought it would be OK to have them at the start of the system”. That’s why I asked if it’s planned to include the tickbox “hide bar number if rehearsal mark is at the beginning of system”

(Hiding bar numbers at rehearsal marks - #4 by dspreadbury)

You can manually hide individual bar numbers using the Hide bar number property in the Time Signatures group of the Properties panel. Granted, it’s manual for each instance, but that’s available to you currently.

It’s considerably faster to drag them out in engrave mode, than to go through all the steps of clicking the bar, ticking the checbox, etc…

But my main reason for bumping this was to remind Daniel and the development team to keep this in mind for future updates …

I’m puzzled. Isn’t this what you want?
barNos2

Is there any choice that your file is an imported XML file that is reproducing the bar numbers as text, which would put them beyond the reach of the Dorico bar-numbering routines?

If not, could you attach a Dorico file (excerpt) that exemplifies the problem?

Nope, it’s a score completely written in Dorico…

In this example, 221 is the problem. I’ve set the barnumbers to appear only at the beginning of every staff, not on every bar. And the box you’ve mentioned is ticked off (Show bar numbers at rehearsal marks)

If you can send an excerpt from an actual Dorico file that demonstrates the problem, it would be easier to troubleshoot the situation.

When I set my file to show bar numbers only at the start of systems, the rehearsal mark erased the local measure number as expected.

(Are you sure the checkbox was unchecked on the specific layout you are observing? Without seeing the Dorico version, it is impossible to tell.)

Do you have a bar number change at 221?

Hi Daniel, no I didn’t have any bar number changes.
Derrek, I’ve sent you the file through a private message

Changing the Rehearsal Marks type from Letters to Bar Numbers in Engrave mode seems to have solved this problem.

1 Like

Yes, that did the trick, but only when using the engrave options rather then the individual option in the options panel. Thanks for the help!