Hiding empty bars

I have made an arrangement lead+SSAA and would like to hide a block of empty staves in the SSAA section in the beginning of the score. How to?

Seier - here’s how to do this:

The basic plan is to split the music into separate flows and utilize multiple frames on a page by editing the Master Page “First”, and controlling what flows show in the frames.

  1. In Write mode, click on the barline where SSAA players start.

  2. Under the Write menu, Split Flow.

  3. Click on the same barline (it should have changed to a Final Barline), and change this back to a normal barline.

  4. In Setup Mode, click on Flow 1 (at the bottom of the page) and deselect the SSAA players in the upper left under Players.

  5. In Engrave Mode, double click on First page icon under the Master Pages section (right panel).

  6. In the music frame, Click on FLOWS, select Filter by Flow: Flow 2

  7. Click on the music frame and drag the music frame on the first page down to give room at the top to add another music frame.

  8. Draw in a new music frame at the top just above the previous one and Click on FLOWS, select Filter by Flow: Flow 1

  9. In the grey area at the top of the Master Page Editor, Click on Copy Page Layout: L-R icon (or R-L if you changed the right page) to make both layouts identical and click on Close Master Page Editor button.

  10. Go to Layout (Shift-cmd-L) Staves and Systems, change “Indent first system of flow by 0 spaces”. Hit Apply and Close.

  11. If you want the first system indented, Engrave Mode, Note Spacing on, click on upper left box of first stave and alt-cmd-right arrow your desired indentation.

  12. If you are showing bar numbers, you will have to make a bar number change in the 2nd flow’s first measure to reflect the correct bar number. Right-click this bar and select Bar Numbers, Add Bar Number Change.

Variations of this can be applied by manually drawing in music frames to suit your material and eventually having frames that use Flow 2 that includes your vocal parts. I believe there are other ways to do this, but this is one way.

Perhaps Dorico could make this eaiser at some point by allowing selected regions to hide empty staves.

You could perhaps just use the Hide Empty Staves feature, which is found on the Vertical Spacing page of Layout Options, to see if this will do what you want, before you try musicmaven’s detailed procedure.

Hi Daniel and Musicmaven

I tried out the empty staves feature as described by Daniel. This almost did the trick - but there is still minor issues:

In the first verse of the song arranged lead is solo. After adding “hide empty staves” to the full score I still se the soprano 1 in the print preview.
In the final vers lead is solo once again. After adding “hide empty staves” so the full score i still see all four choir voices in the print preview.

Everything is written in one flow only. What did I do wrong?

Thanks again :slight_smile:

You might need to check that those bars are really empty : no explicit rests, no hidden (or showing) texts attached to those bars in those staves, and be careful with explicit clefs or meter changes… I sometimes had to split flows where I could not find the problem, copy the bar, delete it, re-add it and merge the flows back. Longer to write and explain than to do it, though :wink:

Seier and Daniel,

I don’t believe the Hide Empty Staves works in many cases because the choices are “After first system”, “All systems” or “Never”. The “All systems” choice doesn’t work in music where you want to hide at the beginning of the work, but never want to hide after that. This is often needed where you have a short introduction then vocal comes in, and only want to show the piano stave, for example, for a 4-bar intro, and then always show vocal from bar 5 even if they have several bars of rest later on. “After first system” will not work if the desired range of hidden measures occurs in the first system, which ironically is often just where it is needed.

Too bad there is not an option “Hide empty staves until first note”.

What I do in those circumstances, for now, is add a Shift+X text item to the otherwise empty bar containing e.g. a capital X, and set it to be transparent. The staves are no longer empty and so they’ll show. It’s a kludge, but I find it better than mucking about with multiple flows.

In the future, we will provide a means of selectively hiding staves, somehow, but I’m not sure when.

“In the future, we will provide a means of selectively hiding staves, somehow, but I’m not sure when.”

Very good news. Near the top of my list.

I should say that my ‘must have’ list is getting shorter as I get used to Dorico’s way.