Hiding running headers

Right. I’m more or less through the first batch of learning curves, those for getting the music in.
Now I’m trying to print, so I’ve got a whole lot of new curves.
I’m preparing materials for a piano concerto, including the orchestral reduction. I input the Solo piano part, and, separately, the piano reduction. So far so good. Then I created a new empty part, and dragged the solo piano and the piano reduction in, since I need a part for the pianist to learn from - in the process, I find the Solo part is listed in the Setup > Layouts list, but is empty and does not show in the full score, though it appears in the part containing solo and reduction. The reduction is not listed in the Setup > Layouts list, but does show in the full score.
What have I messed up this time? Can anyone fathom it, please?
(Ultimately I want to be able to see everything in the score, but print two versions, one with everything bar the reduction, and another with just the solo + reduction.)
And how do I suppress the running header in the two-piano part (solo + reduction); it is entirely unnecessary in that context and just clutters. I can’t make sense of these tokens.

You said you “dragged” the part in. I don’t exactly understand what you did, but the correct method doesn’t involve any dragging.

Create a new layout from the layouts panel on the right, name it whatever you want, and with that layout selected on the right panel, check the boxes of the players on the left panel that you want displayed in that layout.

As you add players to the layout, its name will change to reflect those. But you can double-click on the layout name and call it whatever you want.

Layouts are automatically generated from the players you create, but you have complete control over what layouts you want and what parts they display.

Youll also need to select which flows are present in the layout, if it’s a custom layout that you’re creating. When you create a new layout, you can create a conductors score, a part score, or a custom score. Why that matters is that the score will use that identity to derive its formatting and master pages.

The token you want to use is {@layoutname@}. It will display whatever name you gave to the layout you created. Sky’s the limit.

(I’ve managed to retrieve the Solo and Reduction so they’re all visible in the FS in Write.)
OK. Cracked that one. I’d created a new Player within Setup, not a new Layout. Not helped by the Layouts RH panel being hidden and it took a while to find it. Thanks!
Still don’t understand about the running headers though. I’m happy to have the layout called ‘Solo + Reduction’. But I don’t want that displaying at all, not at all, anywhere. Not needed. If I understand you correctly, the layout name is what’s displayed at the top of every page in that layout. I can change the name, but I can’t suppress it. Is that right? I can delete the name in the RH Layouts panel - but I don’t really want an un-named layout.

Select that layout from the drop down at the top panel, go to Engrave mode, turn on Frames, select that layout name frame and delete it.

If you want all part layouts to show no layout name, edit the part layout master page instead.

Lovely - and thanks, as ever - but I seem only to be able to do that on a page-by-page basis. As there are 52 pages, that’s a bit laborious. Is there a quicker way?

If you want just that one part to not display the name, why not just delete the Layout name in Setup mode?

That’s why you edit a master page. Master pages are First and Default (all pages after the first one). When you make the change there and click Apply, it’ll update all pages.

You want to make sure there are no page overrides.

Check out page 55 of this guide for a short explanation of master pages: https://www.dropbox.com/s/6d2qmdapwqpxyn4/A%20Beginner's%20Guide%20to%20Dorico.pdf?dl=0

piano888 said they didn’t prefer an unnamed layout. But you’re right, that’s another easy way to do it.

Engrave > Frames on. In Master pages, I’ve selected Current Set / Default part. I’ve double-clicked on the running header in the Solo + reduction part and deleted {@layoutName@}. That one’s deleted, but the others are still there, so presumably I’m not effecting a Master change. I tried deleting that frame completely, but it’s still not affected the others. What am I missing?
And I’m still not clear - does Master apply to the layout or the entire project? 'cos I certainly don’t want it to apply to any other parts.

You need to double-click on the Master Page to edit THAT. I think you’re still editing the score. Then you need to make sure there are no page overrides, which will prevent the master page changes from displaying correctly. Page overrides are indicated by a little red triangle on the page icon in the top right panel.

There are two kinds of master page sets by default: Full Score and Part Layouts. Any change you make to the part layout master page will make that change to all layouts that use that master page type.

Sounds like you need to create a new master page set, copy its settings from the Parts master page, call the new master page set “Reduction,” and edit THOSE master pages. Then at the top right panel, right click on the pages and click “Apply Master page change.”

You can create a new master page set at the very bottom right corner in Engrave mode.

Again, I think the link I posted above may be helpful.

I’ll try that - thanks - I did read your Guide, but I’m sorry to say it didn’t work for me. (I’ll give it another go though!) It all just seems so incredibly, time-guzzlingly complicated, when all I want to do is hide the wretched name. Whatever else anyone might say about Sibelius, that bit is a doddle.

To clarify - you want to delete the small header at the top of every page (2-52 or whatever) for that one layout? But you want other part layouts to SHOW the header on each page, as they currently do? If so, then yes, you need to create another master page set called “Reduction” or whatever you want, and apply that new master page set to that particular layout only.

If it were only a couple pages, it would be easier just to manually delete the header frames. But 50 pages would be best changed in one go.

I understand the frustration with master pages. But I promise: once you get it, it really is the best way.

  • Make sure you have the correct layout selected from the dropdown at the top middle
  • Click “Master Page Sets” at the bottom left
  • Click on “Default Part”
  • Click the Plus sign at the bottom to make a Copy
  • Double-click on Default Part Copy" to rename that new master page set
  • In the Master Pages section (just above), click the dropdown and select your new master page set
  • Double-click on that set’s “Default” master page to edit it
  • Delete the frame at the top, or whatever you want that master page to look like
  • Copy L --> R, Apply, Close
  • Make sure there are no page overrides on any of your pages. If so, right-click and remove them.

Thanks - yes, that worked, and your very clear instructions are now safely filed away in my own ‘Useful things about Dorico’ file. :slight_smile:

… until you select some music that has a page heading “attached” to it, hit R a few times to replicate it, and then wonder why editing the heading produces a mess, because you actually had several identical headings printed on top of each other and you only edited one of them … :imp: