HiDPI mode is still buggy and blurry in 2024

The year is 2024. Almost all of humanity has moved on to high resolution displays.
Yet one DAW still struggles to keep up after all these years… Cubase 13.

I’m using a 3440x1440 monitor with Windows 11 scaling set to 125%. Nothing special.
In Cubase 13.0.30, enabling HiDPI with default scaling results in a white line that appears at the bottom of the screen after Cubase has been minimized and maximized again.
Also, some elements of the screen are still blurry, particularly the mixer meters (see screenshot). Clearly these assets are not being upscaled correctly.

The white line bug can sometimes go away if you set HiDPI to 25% or 50%, but not always.
The white line is not there with HiDPI off.

Side-note: Who thought it was a good idea to separate the title bar from the menu bar in Cubase 13?
Now we have a title bar that’s a complete waste of screen space and a menu bar that’s bright white and we can’t change the colour of. Thanks!

Cubase is likely the most feature-packed DAW on the market, that’s why we love it.
But man, Steinberg really needs to up their GUI game.
There are free DAWs out there that look better.

System specs?
It doesn’t happen on my machine.

The white line looks like an older Nvidia thing.

Looks great on my machine.

1 Like

• CPU: R9 7950X
• GPU: RTX 4090 - Latest Nvidia game-ready driver installed, though the white line was there with previous drivers too.
• 3440x1440 Ultrawide monitor
• Windows 11 Pro - 23H2 (latest stable build)
• Windows 11 scaling set to 125%

The white line goes away if I set HiDPI to +25% but comes back if I choose to hide the top Menu Bar.
This behaviour is reversed for the Mixer window. The white line is there when the Menu Bar is hidden and goes away when the Menu Bar is shown.
But I don’t wanna use +25% HiDPI anyway, it’s too big.

When HiDPI is set to “Use System Settings” which is what I want, as soon as you minimize and maximize the window again, the white line appears regardless of whether the Menu Bar is hidden or not. It does NOT appear when using Alt+Tab which is interesting.

Also, the white line always appears when I open a template instead of an empty project.

So basically, if I don’t wanna have the white line on my screen, I have to create an empty project and never minimize it.
I’ll still have the white line in the Mixer window though.

try studio driver instead

No thanks. The game-ready driver has never been an issue with any other program on my PC, including FL Studio 21 and Ableton Live 11.
Like many people, I didn’t buy a 40 series GPU so I could use the Studio driver.

Please don’t try to put the blame on Nvidia here.
There are way too many issues with Cubase 13’s GUI to blame anyone else but Steinberg. If Cubase really does have a compatibility issue with 40 series cards, then it’s up to Steinberg to fix it, not the other way around.

It shouldn’t be too much to ask for a software company to test their DAW with a current gen Nvidia GPU, should it?

Nevertheless, I did do a bit of GPU-related troubleshooting, just in case. Here are some of the things I tried:

• Turn off “Hardware-accelerated GPU scheduling”
• Turn off “Variable refresh rate”
• Turn on “Optimizations for windowed games”
• Set Cubase 13 profile to “High-performance NVIDIA processor”
• Set Cubase 13 profile to Vertical sync “Fast” and “Off”

None of these made any difference.

2 Likes

I already know about that link, thanks. If you fully read my reply to you, you’ll realize that I’ve already followed the link’s instructions to no avail.

Besides, the link states that GUI errors in Cubase 13 / Nuendo 13 were fixed in Cubase 13.0.21, so tweaking the settings isn’t necessary anymore.
So either the issues they resolved aren’t the same as the issues mentioned here, or Steinberg didn’t test with RTX 40 series GPUs.

Just out of curiosity, do you still have this problem?
I work with two 4k 32" Eizo/ Win11 Pro/ Sapphire 5700 Nitro+ and there is no setting on my Cubendo/ Win11 system (125 / 150 %) that ever makes Cubendo appear properly sharp. Its somehwat “sharp” ok, but not as crisp as Studio One, for example, or Bitwig. I realize that Cubase has been around for decades compared to Bitwig or S1, but overall the UI never seems right to me compared especially to Studio One (6)

1 Like

Yes, sadly Cubase still has some blurry elements on high res monitors to this day.
By the looks of it, it doesn’t use vector-based scaling for its GUI like in programs like FL Studio which scales up crystal clear no matter the resolution.