High Latency Issues

Hi I’m having a bit of a latency issue. I’m currently using Cubase 6.5 and an Alesis iO4. The ASIO DirectX Full Duplex Driver I’m using has an Input Latency of 325.079ms and an Output Latency of 56.440ms. I’ve tried using other ASIO drivers but ran into a few problems ([1] would allow my input but would give me no output. [2] would bluescreen of death whenever I change the VST Audio System settings to it.). Any help/fix for this would be greatly appreciated.

Use Asio4All as suggested by Alesis .
http://www.alesis.com/io4
( Docs & Downloads tab )

I presume that’s what the OP used originally, since this interface apparently doesn’t come with any drivers of its own.

ASIO4ALL is THE alternative for sound cards/interfaces that don’t have their own drivers. If that’s what you were originally using, Drebin, it’s possible you’ll need a different interface that includes drivers for your OS (the DirectX ASIO driver is unusable, as you’ve seen), a different PC, or perhaps just a fresh, clean Windows install with up-to-date drivers across the board. I’m not sure there’s any other driver for Windows that would give you better results than ASIO4ALL.

i would have to agree, while ASIO4ALL is a patch, it shouldnt be THE solution. I definitely suggest grabbing an interface with designated drivers. Presonus makes good stuff. The new steinberg interfaces UR series are GREAT. Anything USB. steer clear of firewire.

ASIO4ALL is what’s giving me the bluescreen. I’ve had this happen in Cubase and FL (both paid full). I have also done a fresh windows 7 64bit and fresh cubase (64bit at first but 32bit now) install on a PC I built myself (asrock z68 extreme4 gen3, intel i7 2600k not overclocked at the moment w/ 12GB of ram). The ASIO4ALL worked for a few hours but wouldn’t give me an output option (it would read my input from the iO4 but would show my out put as “Not Connected”). I tried to install the ASIO4ALL drivers from the Alesis link above and that’s when I started getting the bluescreen. I’m in no position to buy any more hardware, but I thank you for your advise.

EDIT :smiley:

I’m happy to say that I have fixed the problem!! I moved my Alesis iO4 from a USB 3.0 port to a USB 2.0 port and that fixed everything. :mrgreen:

Ah, that was an important piece of information!

Yeah, I’ve heard lots and lots of problems with people plugging USB 2 stuff into USB 3 ports. It’s supposed to work, but things clearly haven’t been sorted out there yet.