High latency since 7.5.1 (resolved)

I used to have no noticeable latency but today I tried recording for the first time since the update and the latency is almost a second, even though cubase says it’s only 6ms (as it always has). Makes recording impossible. Might be nothing to do with the update, but nothing else has changed.

I’m using a CI2+ set to 64 samples, the lowest. Yes I’ve checked Cubase is using it. Anyone have any ideas? Thanks…


Off the top of my head, maybe for some mysterious reason the latency rate is not fully “applied”. Try changing it to 128 samples which is still very low and apply it. If it works, you can get back to 64. I assume you have checked your VST Audio System under Device setup, and the dedicated ASIO driver for your audio interface is selected.

Good luck.


Yes checked device setup. I’ll give that a try thanks.

Finally got around to trying this again and no luck. I was recording on this system 3 weeks ago, nothing has changed other than the new update. According to cubase I should not be hearing any latency…

I noticed that no matter what I set the CI2 buffer size too, and what the numbers in cubase say, the latency I am hearing is the same. Another thing I noticed is this new driver called ‘high definition audio device’. I tried to delete it but it re-installs itself.

I noticed that no matter what I set the CI2 buffer size too, and what the numbers in cubase say, the latency I am hearing is the same. Another thing I noticed is this new driver called ‘high definition audio device’. I tried to delete it but it re-installs itself.

Sounds like the internal sound card on the motherboard is enabled…
Disable it in the bios for starters.

Do you have inserts on your master stereo out?

Thanks for the quick reply.

Unless it re-enabled itself it’s been disabled since I built this comp. I will check though. No inserts or sends.

Edit; Just checked and it’s still disabled. I know it wasn’t that anyway cause it’s ASUS and their driver says ASUS, this driver says Microsoft. Can’t find anything online about it either.

USB is not suitable for professional audio.

It was working fine, so USB is not the issue. I had less latency than with my MAudio 2496.

Found a bit more about this mysterious high def audio driver… “Location 0 (Internal High Definition Audio Bus)”

Sounds like it’s for on-board sound but it is disabled in bios, I just checked.

Have you by any chance installed a new video card? I know it sounds strange, but newer cards that use/have an hdmi output also channel sound trough that connection. This is that mysterious “high defenition” sound device. I suspect it is the case, because the Nvidia card I have (altough not an ASUS, but an MSI) also uses that high defenition audio output. Keep in mind that some motherboards have an on-board graphic “card” that can have an hdmi output too. Sometimes you than have to disable not only the primary sound device, but also the high-definition sound device.

I have no idea how to disable this hardware if you do not use an on-board card, because in that case it is not configurable in the motherboard BIOS. However - in my case I just choose my (focusrite) ASIO driver in stead of an high defenition (or any other) device from the pull-down menu in the device setup, and have no latency problem at all…

If you keep having problems you can try looking up the high definition device in the device manager and than just put an check in “do not use this device”. Do not remove the device, because it will be re-initialised at reboot. Just disable it, and Windows will not “see” the device any longer.

Your screenshot shows Asio Guard is activated. Try turning it off. This may have defaulted to on with your Cubase upgrade.


What absolute rubbish.

Couldn’t let that pass unchallenged. Anyway, like others, I strongly suspect that the issue isn’t 7.5.1. I had some problems recently and it was a slow problem tracking it down using LatencyMon and DPC Latency checker. It took several hours but in my case I isolated it to the Blu Ray drive, which was quietly going nuts in the background. Unbelievably (and this really is unbelievable, I would never have believed it if it hadn’t happened to me), merely putting a disc in made all the problems vanish completely.

Funny things, computers.

Windows computers.

Using 7.5.1 and 23gb of template on VE Pro 4 I was on 1024, now its a very very comfortable 256 (7ms in each direction) - I could easily go lower, but that latency is easily good enough for me and I’d rather have it running with plenty of horsepower to spare.

Are you shure you did not unintentionally insert a Plugin, for example a linear phase EQ that causes latency on the system? This additional latency is NOT reported in the window you showed, there you only see the latency of the soundcard. I just tested it with the LP10 EQ which causes about 50-80msec latency but that window further showed 8.7ms latency.
In playback you will hardly notice it and may work a bit with the changed system but as soon as you start to do things live you notice the mess… My first aid in these cases: deactivate the plugs one by one.
Hope that helped a bit.

No new vid cards, or any other hardware since I last recorded with no problems. Only thing new is the latest Cubase update.

I know of the ASUS audio driver cause I always un-check it when updating graphix drivers, it is not installed. If it was it is easy to uninstall from ‘programs and features’, but it’s not there and neither is the mysterious ‘high definition audio driver’. I tried disabling it from Device Manager and it re-enables itself. I also tried deleting and yes it re-installs itself.

Thanks for the reply.

Thanks for the reply.

I tried that and it made no difference. It seems like the CI2 is not the active output, but it is set as the only playback and recording device, in fact the CI2 is the only device it lists.

As I said before the latency I hear stays the same no matter how I set things in Cubase.

Thanks for the reply.

No plugins, I double checked. I also created a new track a few times when checking it.

Seriously, start from the ground up with LatencyMon and / or DPC Latency checker.

If it was not Cubase wouldn’t I have latency problems with Wavelab also?

I used LatencyMon…

Precisely the reason you should consider an internal soundcard.

P.S. I will check out that LatencyMon program (could not view your image).

I have an internal soundcard, MAudio 2496, I switched to the CI2 and it has worked fine for over a year, until now. Works better for me than the 2496 (or did).

My image shows LatencyMon, it says 'Your system appears to be suitable etc." and latency in Cubase; input latency 5.578 ms, output 8.299. It has always been about that and should be fine, but I ‘hear’ at least half second of latency. ASIO-guard says 11 ms, but it makes no difference on or off.

Maudio is not really very good when it comes to drivers, at least in my opinion.

I use Echo Audio gear, simply because they support modern standards such as WASAPI, MMCSS and ASIO 2.2.

RME is supposedly decent but they would never confirm whether or not these standards were used, so I did not buy them but they may do now after going PCIe.