High pass using Cubase stock EQ doesn't seem to work

I have a Halion Sonic 7 patch that has a lot of unnecessary low frequency energy that I wanted to cut out, so I used the Cubase 12.0.60 channel strip EQ to high-pass the signal. As you can see in this screen shot, it isn’t cutting out the low frequency information (FWIW, disabling/enabling the EQ makes no difference whatsoever, which tells me that somehow the EQ isn’t kicking in):

For good measure, I added another low cut EQ as an insert, which also makes no difference:

Not that it should matter, but here’s the Halion Sonic 7 sound source:

Using the channel strip EQ to high pass signals is something I do all day long, and it’s never given me any issues, so I’m stumped as to what may be going on here.

Does anybody have any ideas to help me figure out what’s wrong (and fix it)?

Hi, here it’s working as expected. I notice that you have the “Read” automation active. Maybe you have an automation recorded that is creating this issue?

Here’s a similar thread: https://forums.steinberg.net/t/low-cut-and-high-cut-filters-integrated-do-not-work-properly/121545/1

1 Like

I kind could reproduce this if the PRe HP is automated, then after re-opening, the low-cut is inactive (the automation data is reading fine, just the control is deactivated). Weird thing ist, that only happened once in a while when re-opening the project, most if the time it works, I’ve tried several times, and I don’t really what I did differently… and when opening the Channel Settings window, it suddenly was activated.
So it seem like the issue from the thread you linked isn’t really solved.

But the issue described above has the HC section enabled, and that works here like expected, also with StudioEQ. Tested with the following setup:
empty audio track with the TestGenerator, Square wave at 50Hz, routed to a Group. On that group, tried the pre-LC and the Studio EQ and watch the result on an analyzer.
@Timo00 can you maybe try that on a new empty project and see whether it works?

The PRE section takes place before the inserts, and the EQ bypass doesn’t affect the PRE section.
Try using the high pass from band 1 instead, this will affect the final sound after the inserts.

You don’t say if this low frequency content was already present in the base sound.
It’s possible that the Chopper plugin creates some sort of low freq rumble when it is set to sawtooth or square. I have just tried to reproduce your issue with only the PRE Cut and Chopper, and all I can say is that the clicks it makes do create low freq noise.

Yeah actually, the spectrograph on your image doesn’t look like it comes from Chopper. I have no clue what it could be, especially when you say StudioEQ doesn’t work either.

@m.c - yes, there’s some automation on this track, but it is not automating any EQ settings, so the bug you pointed out is not the culprit here. Good observation though!

@Louis_R - using the high pass from band 1 fixed the issue, thanks! Chopper isn’t creating the low frequency content, it’s coming from the Halion Sonic patch. So, in theory, the pre EQ should work on that, and certainly the Studio EQ I put into the insert chain should work, but in practice, neither do.

@fese - since I was able to “solve” the problem by simply using the high pass from band 1, I’m going to move on and not try to reproduce this at this point, I’ve simply got too much music-making to do instead of playing QA Engineer for Steinberg :slight_smile: But I do want to be helpful in narrowing down any potential bugs, so trying to reproduce this will go on my low priority to do list.