Hint to reduce dropouts

The Problem
On my system if I move a window or change tracks etc. I would get, and hear, audio dropouts.
These dropouts were really annoying, especially when using looped sections while mixing.

After much research using the internet and Cubase forums I determined a solution for my system. It may help other users so I outline my solution here.

Logically with the power of my graphics card, 2GB of DDR3 GPU memory with fast bandwidth, I felt it had enough power to handle the display needs of Cubase.

As we now have to use the Aero Graphics System to run Cubase 8 the OS requires time to do its Aero thing. Even though we can optimize Aero for maximum performance and appearance I don’t think it can use the graphics processor (I may be wrong here)

Cubase, by default, sets its processor priority to “high” (See Windows Task Manager) which seems to be desirable for a DAW. However the Processor Affinity for Cubase is allocated to all CPU predecessors.

On my system I have 8 CPU processors. By changing the Processor Affinity to allow Cubase to only use CPUs 0 to 6 (Uncheck CPU 7) the asio dropout problem completely went away.
It seems that allowing the OS a bit more processing time to its thing really helped.

This solution
I created a short cut to always start Cubase with this affinity.

On Windows.

  1. Create a standard short copy on the desktop.
  2. Right click and select properties.
  3. In the Target: setting add C:\Windows\System32\cmd.exe /c start “Process Monitor” /affinity 7F before the current text.
    e.g., C:\Windows\System32\cmd.exe /c start “Process Monitor” /affinity 7F “C:\Program Files\Steinberg\Cubase 8.5\Cubase8.5.exe”
  4. Change the Run: setting from “Normal Window” to “Minimized”

Hope this helps :bulb:

My Test System
Audio
Behringer FCA1616
Streaming buffer depth = 2000us
ASIO buffer depth = 10.0 ms 480 samples
Graphics card
NVIDIA Quadro K620
Operating System
Windows 7 Ultimate 64-bit SP1
Cubase 8.5

Thanks! I’m not having this problem, but this type of info is rare and hard to discover via Google. (At least in a DAW context.)
Cubase apparently has some nice workarounds, but little clarity about how to use them, or what they do.

In studio one, there is a preferences option to change the CPU affinity permanently within the program.
I wish Cubase had the same option. I have used it in the past when my FireWire driver was hardcoded to use CPU 0
Letting my DAW’s run on only CPU 1 to 7 resolved my audio stutter problem in Cubase, studio one and reaper.
When I later changed to a RME Raydat it was not necessary anymore.
Highly system dependent, but worth having a look at the task manager if any core is using a lot more CPU even before starting the DAW.

I use this too. I pulled down LatencyMon and watched what processes where being naughty. My Nvidia driver likes to park itself on CPU0. I found a few other things to disable that were CPU hogs and not needed.
http://www.resplendence.com/latencymon_using

Here is a good link to figure out the Affinity parameter for those with varying numbers of CPU cores.
http://www.eightforums.com/tutorials/40339-cpu-affinity-shortcut-program-create-windows.html

When my CPU is peaking in cubase, but only using 50% of overall CPU, something other than Cubase is involved.
Using this, I can get much more out of my current rig without the pops and dropouts.

Hm, is it my issue? https://youtu.be/bpoXBUU3NxM

I need try this too.

Is there something for Mac OS does this same processes??? I have been dealing with dropouts in Cubase for as long as I can remember.