History Edit window (Ctrl+H) in .30 defaults to the Top instead of Bottom when there is a scroll bar

History Edit window (Ctrl+H) in .30 defaults with the scroll bar to the Top instead of Bottom when there is a scroll bar present (ie there are more actions than the window can show at once).

This bug was not present in .20 and got introduced in .30 .

This is what we get in .30:

Instead of that (.20):

Original post:
I updated to .30 a couple of days ago. Can someone still using .20 please confirm that when opening the Undo History (Ctrl +H), the view you have by default is your last action?

In .30 the view by default is the first action which is useless and time consuming because you have to scroll down every time to the bottom of your actions History to see what happened last.

Also, Steinberg dev team, please reintroduce localized undos like there was in C6.

I haven’t noticed anything in regards to your undo history, but I have certainly observed some “forgetful” software after the update.

But what does it default to?

This:

Or that:

Mine has always been the bottom.

Thanks, just to be sure are you talking about .20 or .30 ?

All versions to my knowledge have been the bottom pic. .20 and .03 are same behavior.

I have never seen the Edit History default to your top pic illustration. That would not be correct behavior because what I think the user wants to see first are the last operations, and the chance to undo the last operations…therefore the user would have to scroll down if very many operations were executed.

Have you started in Safe mode with preferences disabled to see if you get this same behavior?

Localized undo s iirc, were available up to C9.5 or C10. I agree they should be returned. But it wasn’t like Steinberg decided to remove this for no reason. Often it’s one step forward, a half step back.

1 Like

This is weird, even when I start Cubase in safe mode, the History view defaults to the top…
Am I really the only one noticing this?

Reinstalled C11, used default prefs and it still defaults to Top view for some reason…

Hi,

I checked with Cubase 10.5
There is a difference in 11.030:
When you open History and there are more items then fitting in the popup window
the last item is selected but there is no auto scroll down.
so you have to scroll manually.

In 10.5 it works as expected.

Delta

1 Like

Thanks!!! Finally a fellow user confirming this!!! Thank you for taking the time to check this.

I reinstalled 11.0.10 and it works as expected. So my guess is that this bug has been introduced in .30.

My apologies. I tested this incorrectly.

I was testing with the history window open at the start, then adding operations and it works as intended.
However if you first execute a bunch of operations, more than what fits in the history window, then open the history window, you get the wrong behavior.

1 Like