Hitpoint Detection problems

I’ve just noticed my hitpoint detection is no longer working properly. It seems to add a hitpoint at the END of the bass notes, and not always at the beginning. Have i missed something with the latest update to Pro 8.0.2?

I’ve just spend a good couple of hours trying to figure this out in a blank session just recording bass to a click and the detection always comes back wrong. I’ve reset my soundcard (RME UCX) runnin at 24 / 48k at 96 buffer size, and 128.
I tried to record a video but i could not record the audio as well as the screen, so i’ve attached a screenshot
The minimum amount is zero, low threshold and ALL beats, as you can see it is not picking up the hitpoints as it used to. Any help would be massively appreciated. Hitpoints have been working well up until recently, and not looking forward to having my workflow slowed down drastically by this issue.
hitpoints 1.png

Here is the latest screenshot, back in the main client session now. Most hitpoints are NOT at the start of each bass note, but rather at the end. Really stumped here as to why this is happening.
hitpoints 2.png


I Uninstalled 8.020 update from Control Panel (View Installed Updates), and re-recorded some bass with 8.01.
Hitpoint detection was working properly. I then Re-applied 8.02 update and its working fine now. Of course its not perfect, but no more random transients. New Screenshot attached, same session, re-did the bass part in the same part of the song as the first screenshot.

To be sure, i recorded some bass to the internal click over on my Macbook pro running Yosemite and and the hitpoints were not working well there either, like the first screenshot. How do i roll back on a MAC? I don’ have the 801 update for mac, no longer on the downloads page.

PC Specs: Windows 7/64 - RME UCX - 16gig RAM, tons of hard drive, every Slate plugin, UAD Cards.
hitpoints 3.png

Hitpoint detection still not fixed in 8.0.30. As you can see from the screen shots, most of the detected hitpoint land at the end of the notes instead of the start. This same issue happens in 8.0.20 on both my Mac and my Windows systems. This is a massive workflow killer as i need to manually move / delete almost every single hitpoint now, and i work with a LOT of audio every day. Guess i’ll roll back to 8.0.10 for now, but i would LOVE to see this fixed.

I’ve always found the Hitpoint detection a bit dodgy… Try as they might, their efforts on this are better suited to very transient heavy audio (drums/perc etc), than more ‘musical’ examples.

Looking at your pics, whats occurred as you’ve tried playing with the threshold value…? Do you just lose those hitpoints we see, as you raise it any, for example…? Seems like its totally missed some higher (more obvious) peaks already…


I do play with the threshold quite a bit. For fun i just tried a full mix and all hitpoints were perfect! Which is cool and all, but its bass and percussion / drums where i really need it to work. It seems random. I might try 32bit float recording format and see if that works, i’m using 24/48. If we knew more about the logic of the detection we might be able to find a workaround, but not detecting the biggest transients (which land on the beat mostly BTW) is odd software behaviour.

To go along with this anomaly is the delete overlaps which only works some of the time, and its a process which goes hand in hand with my process: detecting hitpoints / cleate slices / Enter Audio editor, select all / Q / Delete Overlaps!! Then go through and nudge a few things here or there…

I’ve never figured out hitpoints… in all their various warp/tab/hit versions. I cross myself often that I don’t need to use them.

It’s weird because the Tempo Detection now seems to work pretty well.

I (sincerely) want to know how to make it work.