Honest question: do most people not even use retrospective record?

I’ve never used that feature. I don’t really understand the concept either: if you intend to make music, you get your keyboard or input device ready, jam some stuff out and then press record to capture it. Old school.

Retrospective record apparently captures the stuff that you’re not recording, right? What about just looping a section for as long as it takes to get something down?

Maybe someone can explain to me under what circumstance they might need to use retrospective record rather than just hitting record. Maybe I’ll find a use for it in that way.

1 Like

If you don’t use or need the feature, great! Those of us who do use and need it rely on it. And if it’s a feature in the DAW it should work.

It’s unfortunate the OP took such an accusatory tone, but honestly if you don’t use the feature there’s no need to comment further on it.

:yawning_face: Totally.

A lot of times I’m just playing around with sounds when I use retrospective record, for example trying to decide which synth patch to use in a part, and I’m playing along with the track to hear it in context. I’m not really expecting to track something at that point because I’m not even sure what I’m going to play yet, or maybe even where I want to come in with a part. But then what I just did really worked, and I may not remember it if I try to “officially” do it for tracking. That was really my case yesterday when I used it a bunch, just trying to start fleshing out what I wanted to add to an arrangement/recording in progress. And the time or two I used it for overdubs, it was really a similar thing, where I’d gotten notes down already, but was trying to figure out how the controller movements would affect that.

That said, I more often use loop recording when I’ve settled on a sound and now know roughly where I want to play. I may still be refining what I want to play along the way, as well as trying to get tighter with what I’m playing, and then I can comp from that later if no one take had just nailed it.

But maybe there’s also a bit of a psychological thing of the “red light fever” variety, where there’s more pressure on if you’re trying to record versus just playing around and “wishing” someone had recorded what you just did. Oh, yeah, Cubase did. :slight_smile:

1 Like

Okay, that makes sense. Thanks. :slight_smile:

Someone was just practicing for their speech at the upcoming wedding.

Huge addition to my workflow.

@rickpaul ~
I appreciate you taking the time to read through my posts (past and present) and replying in detail. However…

I do not believe using VE Pro is a “special circumstance.” Yes, it’s 3rd party software—but I considered this years ago and have had the exact same issue using VE Pro only on my primary computer and/or only loading instruments only in Cubase.

The fact of the matter is not many people use retrospective record—let alone thoroughly—so Steinberg hasn’t given a sh*t one way or another if it works. Thus, the initial question I presented.

Just jumping back in here to add some observatiosn of where and when this feature breaks -

  • I have a LOT of midi controllers, and if I have many of them checked in the “all midi” button retrospective record almost never works. I think this is because I’m filling the buffer with a bunch of data and it loses it / hits the end of the buffer.
  • if I have “return to start position” enabled on the cursor, the midi will often not appear at the right position. I think this is fairly repeatable, but I can’t get it to happen every time so I have no concrete way to reproduce it.

I hope this is something the Steinberg team will look into. It’s quite quite annoying as it is now.

I wasn’t referring to VE Pro, but rather MIDI over LAN and Lemur, both of which the Steinberg rep mentioned in the specifics as to where this had been observed, and which you mentioned having in your environment.

1 Like

I rarely use Retrospective Recording, and it works fine (for MIDI). I hadn’t noticed any bugginess or oddities with it.

It’s basically just a Play Notes into Memory and Copy/Paste function for me. I don’t really have high expectations of it.

I don’t use it that often, though.

1 Like

Your question was ambiguous. It didn’t really state that you were looking for specific examples. It seemed like you were questioning whether or not his use of the term “crippled” was apt.

You said "what do you mean by “crippled?” and not "How has it been “crippled?”

That made the question seem passive aggressive, as if you were asking him to give you the definition for a term most 12-year-olds would easily comprehend in the context used here.

Simple misunderstanding :stuck_out_tongue:

1 Like

Thanks for the reply, @rickpaul. I understand it’s difficult to measure someone’s emotional intent online, and I apologize if my reply to you seemed opposing. I very much welcome your input on this subject.

I’m simply pointing out that—in the ten years this bug has been around—I’ve gone through several different computer systems (Mac and PC), many audio and MIDI peripherals, plugins/apps, and I haven’t used Lemur in many years, yet this issue persists. As I mentioned, I still get these retrospective record errors when I have everything loaded inside Cubase, without using VE Pro.

@GPnicolett ~
I, too, have wondered if the number of external MIDI devices could be the cause of the problem. I reduced the “all midi input” down to only keyboard and MIDI fader controller but, unfortunately, it still happens.

Concerning your second bullet-point, I get the same errors when I jump back to where I started playback and then try to redo whatever I’m working on. For me, it’s when I use the command “restart from last stop position.” However, this equally occurs when just playing straightforward.

With respect to the emotional intent portion of your comment, I wasn’t reading anything into that, just simply trying to clarify that my comments on the environment were not related to VE Pro, which had not even been mentioned in the Steinberg rep’s quote that I linked on this issue. The two parts I’d noted from the response you’d had in the earlier thread did mention using MIDI over LAN and Lemur, both of which were mentioned (along with a few other components, which you had not mentioned).

That said, if you’re also seeing this in plain old Cubase with a single USB-connected (or traditional MIDI cable-connected) MIDI controller and only using instruments inside Cubase, that would seem to rule out the messed up timestamp due to additional protocols that I was guessing might be what the Steinberg rep was suggesting could be involved based on the devices and protocols mentioned.

For better or worse, though, the bottom line is that Steinberg has to find a way to reproduce the problem, or at least get a clue to the specific nature of the problem, in order to address it. And, of course, there are many of us who aren’t seeing this issue at all, but are using retrospective record regularly, which suggests there is something specifically related to environment and/or workflow that serves as a catalyst.

I don’t know how frequently this occurs for you, but, if it is fairly frequently, maybe something like taking some video of what is going on when it is happening could help someone figure out how to narrow it down.

Also, with respect to the rest of your most recent post above, FWIW, I pretty much always have my playback preference set to start the transport where I started playback, not where I stopped playback. (I only use the latter occasionally when editing audio, so it would never be my setup in the cases where I use retrospective record.)

FWIW retrospective record regularly works here in VEP Pro tracks (and also regularly doesn’t work).

I’ll video it next time it happens.

Love retrospective as it kills red light fever… I always make sure that I press stop in the play when I’m at the end of a bar that way if I use it not in lanes I can line it up easily…

Retrospective record is how I record midi most of the time - just playing along during playback. Love it. But I have to agree that 4 bad things often happen here:

  1. The buffer is empty. Could be I just hit stop and start one time too many, seems random. I’m not sure, could be a regularly committed user error. Sometimes I can get it back using inspector retrospective record section (hard to find visually in 13! ).
  2. The retrospective recording is early, despites the track having latency compensation on. This is a regular thing. Normal recording will be on time, retrospective too early.
  3. Recording is time condensed. Although this is a rare one.
  4. More often than 3., I’ll get incomplete recording. Like 4 bars out of 8 played in during one playback or somethingike that.

3-4 are tricky to track and reproduce, unfortunately.

@rickpaul, thanks again for the response. I think the confusion here is I labeled VE Pro as “MIDI over LAN” in that original post, only to simplify that VE Pro was, in fact, MIDI transferred over LAN. Not that I was actually using the software, MIDI over LAN.

Your third paragraph is exactly the issue we (who have been experiencing this bug) have been trying to do for years: none of us can find a way to reproduce it.

Going back to what I said about trying everything I can think of, one of those ideas was to recreate my template verbatim in Logic Pro (which I know equally as well as Cubase), and not a single time have I ever had any kind of problem/issue/hiccup/etc with Logic’s version of retrospective record (AKA capture midi). This was using all the same hardware, 3rd party software, key commands, and idiosyncrasies.

As I keep pointing out, something was changed in Cubase 7.5.30 that was not present in Cubase 7.5.20. Only Steinberg would be able to pin-point exactly what that was.

I’m not sure how applicable to what you’ve been seeing, but I just found a case where I could reproduce an issue with this in my recording just now. Check out this screenshot (results after inserting retrospective recording as linear data):

The scenario is, I was playing along with the recording from the Instrumental through Bridge 2, but I only played during the Instrumental and Bridge 2 – i.e. I wasn’t playing anything during Bridge 1. Two times in a row I only got data in Bridge 2, nothing in the Instrumental.

Earlier in this session, I’d been recording multiple parts with no problem, including one part (seen in the Pigments track a couple tracks above the MiniFreak track where I had the issue) where I’d rested for almost half of Bridge 1.

That it happened twice in a row (I’m not going to try a third time as I just want to track the Instrumental section so I can take a dinner break then do some practicing) makes me wonder if there is some issue where, if you rest a certain amount of time (bars?) it decides you didn’t want the part(s) before the rest, only the part where you resumed playing.

Oh, and just to follow up slightly, I just tried doing only the Instrumental section, again with retrospective record and inserting it as a linear recording, and that worked fine, so it’s not something about that section of the song or any such thing.

1 Like

I think it mostly depends on how you use retrospective recording and what you expect from it? I mainly use it as a tool to capture everything I played on a certain track. To make sure that if I played something I think is worth recalling I can still capture it. And I don’t care if it’s 1,2 or 3 bars behind? I can drag it to where it needs to be. As long as the recording itself is what I played, regardless of the starting point!
I also think retrospective recording wasn’t meant to replace or even compete with normal recording? It was meant to capture those moments where you played something and forgot to record but wished you’d recorded it? So for me it doesn’t even has to be perfect on the bar where I started. As long as everything I played is there! After inserting I can drag it to anywhere I’d like it to start?

I never used it for CC data . I really don’t see the point in using it for that? You might as well start a regular (cycled) recording for that and record until you get it right ?

So I think your perception of how retrospective recording should work is a lot different from mine?

I think you see it as a tool that can (and should be able to) replace normal recording.

I see it as an extra that can save my day when I didn’t or forgot to press the record button. So I’m at least still able to capture what I played. So I don’t care if I have to maybe drag it it few bars to get in time? I’m already glad I could recall what I played!

Under normal circumstances I will always use ‘record’ and not rely on retrospective recording!

2 Likes