Honest question: do most people not even use retrospective record?

For ten years — for TEN f-ing years — retrospective record has been crippled.

I’m open to argument if you need me.


Honest answer: myself, I don’t.

Could you be more specific, please?

I use it.

Never used it

I use it often. How is it “crippled”?

Use it every day. One of my favorite features of Cubase. Especially because you don’t have it hit play to use it.

What do you mean by “crippled”?

I use it quite a lot and it seems to work ok for me.

I use it a lot! For me It’s not crippled in any way? It’s a great feature!

It’s one of those things I have forgotten about. Should use it, but have not done so.

1 Like

Thank you for all the replies.

The TLDR version:
There seems to be an issue with the buffering and the recorded position of MIDI data when using retrospective record. See my old topics below for visual examples.

The more detailed version:
Looking at my past threads, I see the issue with retrospective record started even earlier in 2011 with Cubase 6, although I remember 7.5.30 was exactly when the consistent unreliability began. Let me explain in more detail below:

The problem I continue to have is half the time I use retrospective record it will either have created a 1-bar region with the MIDI information in it, but the data will be anywhere from a few to dozens of measures earlier or later from where I started playback and outside of the region borders; OR, if I’m already in the key editor trying to re-record CC data, after hitting retrospective record, the CC data will be way off and not even close to where I started playback and outside the region borders again.

In Cubase 13, the above descriptions still occur, except now there’s a third issue I’ve been experiencing: when I hit retrospective record, the MIDI data will be at somewhere like negative 29. But, unlike the previous two issues, I cannot select any of the MIDI data to copy back to the location it was meant to be recorded at.

Between this problem, the Record-in-Editor button blunder, and the “new audio drivers found” dialog box, I’ve come to a point of bitterness.

Noun, section 2.

See above post :point_up_2:

See my long post above. It has been broken and unreliable for years.

Works here when I use it. Of course, what’s needed from you is a step by step reproduction sequence that would allow someone else to see the same problems with it as you do. Such as How to format a bug report


It can be useful to be pointed to an area to look for bugs in.

I’d like to take a closer look at it and see if I run into these issues too.

I use it very often. It’s a brilliant feature.

I wish so much that I could provide exact steps to reproduce this but it’s impossible since it’s very random.

As I mentioned above, in 7.5.20 and earlier retrospective record worked just fine, but with the 7.5.30 update all of this began and has stayed consistent up to today.

The fourth link I provided above is the post I made immediately after updating to 7.5.30. Something deep inside Cubase MIDI related was changed in that update.

I just skimmed through that post to get an idea, and it seems that this post in the thread gives some Steinberg recognition of the issue:

And your response in that post would seem to confirm you are among those who have some of the special circumstances referred to:

The thing is, when you post a general comment that suggests retrospective record has been broken for a long time, without mentioning those special circumstances, you’ll get a lot of responses like those you’ve got here from people who do not have any of those special circumstances that may relate to this issue. In fact, to add mine:

I’ve used retrospective record a fair bit without problems, and I only started using Cubase at V9.5. In fact, I used it a whole bunch of times yesterday in 13.0.20 with no issues whatsoever, both for grabbing initial MIDI parts while ad-libbing over what I had in my track to that point and then overdubbing controllers (I think just mod wheel) on some of those parts.

But I don’t have any of the special circumstances listed. I was just using a USB-connected MIDI keyboard (Roland A-800PRO).

It sucks that this hasn’t been resolved for those who are using MIDI over LAN, but it might have be more useful if you’d clarified those special conditions in your post, perhaps drawing in more readers who have those same special conditions, where maybe someone would have a way to reproduce the issue, and perhaps helping Steinberg revisit the issue. (I’d probably guess that it may relate to timestamps getting messed up somewhere in the chain of communications, probably only intermittently if it isn’t happening all the time, based on the symptoms. But that is really just a high-level conceptual guess based on the notion that the underlying communications’ being different from the simpler cases like mine.)

Seriously? You sent a link to the dictionary as a response

I was gonna try and help you, but not anymore.

It’s also been broken for me in the exact ways the OP describes.

It’s difficult to reproduce. It will work sometimes. It will not work othertimes. Right now, it’s working for me. Later today, I will get one bar of nothing placed in a random position on the timeline, with my recording either stashed wayyy to the left of the midi region that popped up or no midi at all.

No idea how to reproduce it yet it’s been happening for years - quite like that damn locked midi automation bug.