Horizontal/Vertical Spacing

Hi all,

I’ve come from Lilypond and I’m a bit confused at how Dorico works in regards to spacing. Pictured below is Dorico’s attempt at layout. I’ve tried to tweak the following two pages with manual overrides, but not been able to achieve a nice result. Is there a button called “make beautiful” that sets the music with proper spacing, instead of cramming everything on the first page?

Hi Nick,

If there a lots of manual overrides then there’s a good chance that there’s something you can do to avoid them… if that makes sense…

One thing I would highly recommend toying with is the note spacing (in Layout Options). Make sure all of your System and Frame Breaks are removed first.

Can you attach your project so we can see what exactly you’ve already done?


Here’s the project. I ended up with some nice spacing after some manual overrides.

Cherubini Trio II.dorico (781.3 KB)

Is there away to achieve this layout, or something similar using default settings?

I haven’t opened your file, but Layout options >Note spacing and Layout options >Vertical spacing >ideal gaps should be enough to get a very nice result without any manual override. Should there be one, it would probably be a Frame break.
Once you know what those settings do, you’ll feel much more at ease with Dorico’s workflow.

1 Like

Yes, Dorico doesn’t ‘balance’ the systems across a spread; and the last couple of systems may need a bit of help. So it’s not uncommon to need a Frame break across the spread and one or more System Breaks at the end of a flow.

As said, the “Ideal Gaps” in Layout Options will set the minimum distance between systems. Dorico will fill the page according to those, until it runs out of systems. Then the page is justified to fill the whole page.

So you could use a larger Ideal Gap between systems. But if you have pages with a longer flow, you might then need to cram more systems on a page with Frame Breaks! So, swings and roundabouts.

1 Like

Here is as file in which I changed the inter-system setting to 15 in Layout Options > Vertical Spacing.

To get the orphaned staff to fit before the Fugue, I changed note spacing to 3 7/8. That did have an effect on the final page of the part, which I could have fixed by adding a Frame Break to the start of the Fugue section and changing the note spacing back to 4 in the engrave menu.

Cherubini Trio II changed.dorico (1.2 MB)

I thought it was you! It’s good to see you have finally done something sensible. :joy:

On top of what the others have said, I notice that you also have a few (maybe unnecessary?) page overrides:

Is this just your attempt to get a blank page at the beginning or is there another reason?

Feel free to send me a fb message if you need to, although, there are more useful people here than me (and I would always encourage you to check in here anyway!).

There are also some orphaned Flow Heading frames here—I’m guessing you started locally editing them/deleting their contents before all the music was entered. This also constitutes a page override, essentially freezing them in place. As you have it now, they won’t affect the printed result because they’re empty. But if you’d decide to switch Flow Headings on again or change the layout in another way, they are liable to result in confusion down the line. Generally it’s best not to concern yourself with the layout until all the music is in place, and then try to find & adjust as many global Layout Options as you can before resorting to local, manual edits.