How can I change the timing of two instrument tracks to be in sync with other instrument tracks

I have Cubase 12 Pro.

I have a large project (audio and instrument tracks) which was in sync at 66 BPS. But it wasn’t in sync with the project tempo. I needed to do this to get audio tracks (guitar etc) in more accurate timing.

After trying and failing using tempo detection, beat calculator etc I found out that all my tracks (audio and instrument tracks) except for two instrument tracks (bass and drums) were perfectly in sync with a project tempo of 71.83 BPM.

These two still play at 66BPM (its seems) even though all others are ok (audio and instrument tracks) at 71.83 BPM.

How can I change the timing of these two instrument tracks to play in sync with the rest?

The bass and drum tracks were made using other plugins outside of cubase originally.

Now I’m using halion sonic acoustic bass and copy and pasted the old bass midi notes into this track, but it still plays at old tempo.

When I simplified my project in a completely new empty project down to 3 tracks (piano, bass and drums) using a project tempo of 71.83 by copying and pasting the piano (halion sonic Verve) midi notes, the halion sonic acoustic bass notes and drum midi notes into their tracks, the piano is ok but bass and drums still seem to be playing at 66 BMP (ie now faster than the piano tempo).

Again, how can I change the timing of these two instrument tracks to play in sync with the piano (which would be in sync with all other tracks in my full project)?

Hi and welcome to the forum,

Instrument tracks are always following the Project Tempo. Once you change the tempo, the Instrument Track will follow.

I think, you had wrong tempo of the Instrument Track, then you corrected it, but the MIDI data moved too. So it doesn’t match the other tracks anymore. You would need to time-stretch the MIDI Parts.

Thanks for the welcome.

That sure was what I was looking for, after looking in all the wrong places for ages.

So very grateful.

66 / 71.83 = 0.918836

44.100 / 48.000 = 0.91875


1 Like

Yes Im sure you are right. I probably got something muddled. But I just finished time stretching both bass and drum tracks into sync in my full project and all tracks work great now.
Thanks for your calc. This will also give me better insight into how timing works.
in Australia

It’s fascinating how frequent this sample rate mismatch pitfall is. I wonder why some people seem to always have to really pay attention and watch out for it, while others don’t encounter this problem at all.

For me, when I try to import something (anything), IF it’s a different sample rate, Cubase throws a window and offers to resample it to the correct rate, which I do. Could it be that you clicked “Don’t ask again” one time, and now files are imported “as is” into projects?

Still, you can go to the pool and resample them manually after import, there’s no need to manually stretch them, but that “let me resample that for you” window at the very very first stage of import is so much easier in my opinion.


I was copy and pasting (or dragging and dropping) audio and midi files from an earlier project (a kind of back up with a different name at 66 BPM) to this current one in the same project folder (at the new BPM, 71.83) Changing things in the old project was not working. I don’t know where otherwise the midi files are stored so I’m not sure what you mean by “import something”
There are no midi files in the pool that I know of, so how can I resample these there? Or is there still lots I don’t know about midi files and where they are stored when they are in instrument tracks?

MIDI should follow tempo no matter what. 2 bars of 4/4 are 2 bars of 4/4, be it at 48 bpm or 120 bpm. But with audio it’s different. If everything was recorded properly - at the proper sample rate that is - in the orginal project at 66, the thing to do if you wanted to up the tempo would be to turn on musical mode for audio events and then change the tempo. At that point MIDI would follow, audio would follow, no matter the tempo. Are those tempo numbers (66, 71.83) a coincidence, or is it that something was not quite right with the original project at 66 from the get go?

When I drag and drop audio, from the desktop or any other folder to an active project in Cubase. If there is a mismatch (e.g. my project is at 48K/24bit but the file I’m dragging into it from the desktop is 44.100/16bit) Cubase tells me about it once I release the mouse button (after the drop of drag-and-drop). So that I can have it changed to 48K, and it plays back at the correct tempo and pitch. MIDI always imports (from drag and drop) fine.

Hi perov8.
I am wondering if this is what you’re after.
Dom Sigalas is an amazing Cubase tutor on YouTube and I think this particular video is to your requirements.


I started with Cubase LE 10 which came with a zoom 16 track recorder, which I now use for my audio interface.

Originally I played an early version of this song live (at a local market gig) with a backing track using a boss RC 50 looper. Later I redid it including orchestration using LE 10. Since then I upgraded to Elements, and now Pro.

What happened was I took the backing track wav file, which was recorded with a click track, and imported it into my current project in order to do a more professional job of it. In doing so I incurred a mis-match, somewhere along the line, probably with the sample rate out of sync with laptop (48K vs 44.1).

I recorded the revised tracks from a uniform track (wav file), not a click track.

I ended up finding the click track was out of since eventually, and did all my editing from the uniform original backing track, was was a pain. Since I have about 24 tracks.

Although it was working in 66 BPM my guitar tracks were not quite what I wanted them to be timing wise. Now having the advantage of Pro 12 I wanted to get this recording really good.

I started researching Tempo detection and did in fact decide to use Dom Sigalas’s method that Darchy suggested. That’s where I learned of the beat calculator.

The only track I could really use for tempo detention was the backing track wav file. This failed because, unlike in the vids, the tempo track turned out to be complete confusion (thousands of tempo changes that didn’t make sense since it was a uniform track).

Dom’s method failed because of many blocks. Cant remember now, but including greying out of tempo detection on many tracks, unable to get into musical mode, failure with “set definition from tempo”.

So I resorted to manually find the tempo by trial and error knowing that the wav track was uniform. This was 71.83. Don’t ask me how. The click track now is in alignment with all my tracks thanks to time stretching the 2 that weren’t.

Thanks again everyone.

1 Like