How can I prevent Cubase form auto-connecting the CMCs?

I have hacked my CMC-FD module as a conventional midi controller (defining the CC numbers sent in Max MSP). It all works great, as long as I deactivate the CMC-FD in the devices menu in Cubase. However, whenever I restart Cubase, the deactivated CMC-FD shows up again in the devices menus. It also doesn’t remember the in- and out-port I set last time! Instead, it reverts automatically to the USB midi port of the device. Is it possible to prevent that form happening? Otherwise, I will have to deactivate it every time I start Cubase, before I use it as a midi controller, which is really a PITA …


If you use your Max/MSP patch as an Input and Output of your CMC-FD, then the issue is on the Max/MSP side. Definitely, if you are on Mac (I’m not sure about Windows). I have the same issue.

Max/MSP patch is a new MIDI device every single start of Cubase, from Cubase point of view. For some reason, Max/MSP’s MIDI port’s ID changes every single start. So Cubase cannot recognize it as the same MIDI Device (for Remote Controls).

Thank you for the valuable hint! But I am actually not sure, if I quite get you:
My problem is Cubase re-assigning the In/Out port of every CMC device automatically on start up. That happens, when I deactivate the ports completely, or if I assign them to other ports. I did not assign them to the virtual Max ports, but to the Mac OS X IAC ports, which I did not change.
Can you assign the CMC FDs to any other port than the CMC USB device itself with Cubase remembering that on the next program start? If so, that would be all I want, indeed. Even if that would be a hardware port. Or are you trying to say, I should completely deactivate the 2 virtual ports form Max? I could do that! But I need quite a lot of IACs …


No, it’s not necessary to deactivate these 2 Max virtual MIDI Ports. If you are not using them as an remote device in Cubase, it’s OK.

I see, if you are not using Max virtual ports as a substitution of the CMC-FD MIDI In/Out, then it’s not related to my post. But to be honest, I don’t know, if the IAC driver is not affected by the same issue too.

And I would guess, Cubase really tries to connect to the CMC In/Out automatically when starts. :-/

I have written to support about this … and wait since almost a moth for reply, well, the usual … let’s see, when I get an answer. I could be possible. If I remember correctly, the devices showed up, but were not accepted by Cubase, before I did the firmware update. So, maybe a firmware downgrade could help …

hi, just saw this so sorry if it’s moot now–
but if you connect the PD after starting Cubase, I think it won’t show in the device manager, but still function as a conventional MIDI controller I think.

This si probably Windows only. On Mac it is recognised.

Or the reason behind is, the Device is recognised, but the MIDI Ports are not assigned automatically.

I’m doing a similar thing, using Bome Midi Translator. As long as the CMC driver is installed, Cubase will grab the CMC device. I haven’t found a way to hide it from Cubase.

I have my CMC-FD and TP plugged into a switched hub that I turn on after I launch Cubase to get around this.

may I ask what quote you are referring to, with the “similar thing”? I am currently checking out Bome after purchasing a code (offered here on the forum) that uses this translator to have the CMCs talk to ProTools, and am exploring the options of rewriting scripts for another DAW I use (Samplitude).

I’m referring to the OP.

I use a CMC - FD as a continuous controller in Cubase. I have it setup so that I can change what CDs it sends for each of the four Faders. Also I have a CMC-TP for sending commands, and its fader as one more continuous controller.

ok thanks. Would you say the Bome thing is rocket science for someone with a fairly basic handle on all things MIDI?

I have also found an alternative, how it could be used: the iconnect midi interfaces have an USB port and you may even connect a hub to the port. This way, it should be possible to connect every CMC controller to the computer whiteout Cubase seeing them as such. Haven’t tried it yet, but it should work.