How do I add Ivory 2.5 piano to Dorico?

I’ve tried adding “Ivory”, “Ivory II” (which had been previously suggested in an earlier post), and also “Ivory 2” to the Whitelist but the plug-in still fails to show up among the Play Mode options for virtual instruments when I re-start the program. I also recently update Ivory to the latest version (2.62). Thanks for any help!

  • D.D.

Please do ‘Help > Create Diagnostics Report’. That creates a zip file on your desktop, please attach here. Thanks

Done. Currently the Whitelist says “Ivory II” but it doesn’t show up (I also as I mentioned tried other combinations):
Dorico Diagnostics.zip (716 KB)
Best!

  • D.D.

There is an Ivory found under ="/Library/Audio/Plug-Ins/VST/Ivory.vst but that one got actually blacklisted, i.e. the vst2scanner found an issue with it and blacklisted it, so it won’t get loaded. This is a safety measure so that it may not crash the audio engine.

I don’t know Ivory or Ivory II, is there a second Ivory with the name ‘Ivory II.vst’ somewhere installed on your system? If so, you need to add the path to it to th VST2 Plug-in Paths list.

Just getting back to this (!): Not sure what’s going on with that blacklisting. It appears to be the “active” Ivory (created/modified Jan. 17/20, etc.) and no other variation of “ivory .vst” shows up when I search my system. Ivory also loads fine in other programs and as a standalone. I also just tried re-installing the latest Ivory 2.6.1 Ivory for Mac (including Catalina) update just in case it helped - it did not (still not showing up in Play Mode). Thanks for any other thoughts.

  • D.D.

Please do the following: Open a Terminal window (/Applications/Utilities/Terminal.app) and type/copy following command:

/Applications/Dorico\ 3.app/Contents/Applications/VSTAudioEngine3.app/Contents/Components/VSTPlugManager.bundle/Contents/Resources/vst2xscanner -p /Library/Audio/Plug-Ins/VST/Ivory.vst

The output please copy and paste here. Thanks

Here you go:

Last login: Sat Feb 15 15:01:43 on console

The default interactive shell is now zsh.
To update your account to use zsh, please run chsh -s /bin/zsh.
For more details, please visit https://support.apple.com/kb/HT208050.
2019-MacBook-Pro:~ user$ /Applications/Dorico\ 3.app/Contents/Applications/VSTAudioEngine3.app/Contents/Components/VSTPlugManager.bundle/Contents/Resources/vst2xscanner -p /Library/Audio/Plug-Ins/VST/Ivory.vst
Ivory VST 2.6.1 b201 x64 built Jan 17 2020 15:33:48 instantiating in 64-bit mode
resolveAlias: resolving to /Volumes/SAN DISK - 2 TB - DRIVE/Install Files/Ivory Items took 29.6616 ms
Prefs _items_path set to /Volumes/SAN DISK - 2 TB - DRIVE/Install Files/Ivory Items/
Prefs _prefs_path set to /Users/user/Music/.com.synthogy.ivory/
Starting thread 0 7fe0080300f8
found


Opening a secure and authenticated connection to License Daemon…
pace::eden::openSecureConnectionToLicenseD (true…): Successful

2020-02-16 00:12:52.955 vst2xscanner[46347:407510]
2020-02-16 00:12:52.974 vst2xscanner[46347:407510]
License information for Ivory II Grand Pianos:
Location: Machine with serial number 159a7a90-0bd0-11ea-902f-10ddb1c6a6d8.
State: Active; Authorized

2020-02-16 00:12:52.982 vst2xscanner[46347:407510]

Finding Unauthorized auths for Ivory II products

2020-02-16 00:12:52.995 vst2xscanner[46347:407510]
2020-02-16 00:12:52.996 vst2xscanner[46347:407510]

Finding Unauthorized auths for Ivory 2.5 products

2020-02-16 00:12:53.003 vst2xscanner[46347:407510]
2020-02-16 00:12:53.003 vst2xscanner[46347:407510]

Finding Unauthorized auths for Ivory 1.7 products

2020-02-16 00:12:53.009 vst2xscanner[46347:407510]
2020-02-16 00:12:53.009 vst2xscanner[46347:407510]
########## Verifying authorization for Ivory II products
2020-02-16 00:12:53.241 vst2xscanner[46347:407510] verifyAuth success
2020-02-16 00:12:53.242 vst2xscanner[46347:407510]
2020-02-16 00:12:53.242 vst2xscanner[46347:407510] verifyAuth success 1688633330


Decrypting the keystore…
pace::eden::decryptContent: Successful


Verifying the content signature…
pace::eden::verifyContentSignature: Successful
threadCleanupFunctionCalled 0 7fe0080300f8

<?xml version="1.0" encoding="UTF-8"?>

/Library/Audio/Plug-Ins/VST/Ivory.vstInstrument5653544976727969766F72792E7673745653454976727969766F72792E767374Ivory.vstSynthogyVST 2.42.6.3.0010103
2019-MacBook-Pro:~ user$

Hi, the output looks pretty good, so I wonder why it gets blacklisted.
First thing to try then, delete the file /Users//Library/Preferences/VSTAudioEngine3/Vst2xPlugin Blacklist VSTAudioEngine3.xml and restart Dorico.
Does it again get blacklisted?
If yes, then we need to look further. From the output of the terminal window, it seems that under /Library/Audio/Plug-Ins/VST/Ivory.vst is only a symbolic link, rather than the binary itself. Could be that the vstscanner is choking on that, even though the output does not suggest so. So could you please check, is it just a symbolic link or the real plug-in?