How do I change the sample editor ruler subdivision?

Hi there!

I am trying to “free warp” some audio material to 1/8 triplets. Looking at the audio wave in the sample editor with the sample editor audio ruler settings to bars+beats the subdivision markers still show up as 1/16s. This is very inconvenient when trying to warp the audio to 1/8 triplets (or any other triplets).

How do I change the subdivision of the ruler settings in bars+beats mode (preferably to the quantize resolution)?

A suggestion for improvement:
Also, in the AudioWarp function/panel of the sample editor, the resolution can only be set to 1/2, 1/4, 1/8, 1/16, 1/32 and 1/64. It would have been nice if the triplet and dotted resolutions (from the quantize resolution settings) were also available as a warp resolution parameter although I guess they could be selected by correct setting of the swing parameter. But it would surely be easier and more convenient if these values were selectable instead of having to do the math yourself.

Kind regards

I’m having the same issue. I’m editing a bass part in 12/8. When the part is sparse, it’s easy to alt-click the track to split it, and then ctrl-alt-click and drag to align the notes to the grid in the project window. However, when it gets busy, the sample editor’s free warp is the only convenient tool to get that job done, but the grid is in 4/4 with 16th note subdivisions.

The most feasible solution I have found is to go into the tempo editing menu (Ctrl+T) and hit the little “process bars dialog” button which should be the rightmost one at the top. There, you can set it to “reinterpret bars” to 12/8 which will give the eighth-note triplets for the bar range indicated. Of course, this only works if your project is actually in some compound time signature like that.

This certainly is an issue that should be dealt with.