How do I consolidate multi-bar rests?

Dorico is separating this 17-bar rest into three groups, but I don’t want that. I want to start with a single, 17-bar rest. Why does Dorico insist upon separating these? And how do I fix it?

(Note: I’ve skimmed other posts on this topic, most of which relate to disabling condensing. But condensing is already disabled in my project, so I remain baffled.)

It could be any of several types of object. Are you showing signposts? That will probably give the quickest clue as to what’s going on. We can only guess from a picture.

Thanks for the reply. This is my very first project in Dorico 4, and almost all defaults are still in place. (I’ve only changed a couple of fonts.) All signposts are showing except for two (which is the default):

When this happened to me it was because a crescendo was extending past the end of a barline into a blank measure. It threw all of the multimeasure rests in other parts off. Took me forever to find the cause!

My next guess is that somehow one of the bar rests in bar 12 was made explicit, perhaps by hitting O for force duration. If you choose View > Note And Rest Colors > Implicit Rests, that will show default rests in grey. If any rests are still black, try selecting and deleting them.

Posting the project file itself will take the guesswork out of it.

Thanks to all for these tips and suggestions.

When viewing implicit rests, they all turned gray. None remained black. Here’s a truncated version of the project (just the first two, unfinished pages, because the client is secretive).

Key : Keyhole 1.1 copy.dorico (998.4 KB)

Thanks again in advance.

Select bar 12 in the System Track, hit the checkbox to select everything in that bar and hit Delete. What is in there, we may never know but that gets rid of it.

2 Likes

I could not see anything hidden there. Perhaps did you have en extra staff, that you later deleted but wasn’t completely empty?

To fix it, add another empty bar <Shift>B, then type 1b to add a bar. Use the system track to delete the offending bar.

1 Like

Thanks!!

Thanks for your solution, as well!!

The Clarinet layout does not display this behaviour, so it looks like the cause might be in the Piano part.

After a fair bit of experimentation, I think I have identified the hidden object which is causing the 1-bar rest to not show as a multi-bar rest.

My procedure:

In Full Score layout (or Piano layout), select bar 12 using the System Track.
Edit > Filter > Pedal Lines.
Press Delete.
The 1-bar rest now becomes part of a 16-bar multi-bar rest.

Edit > Filter > anything else does not achieve this.

So it looks as though there is a hidden pedal line in that bar somewhere.

= = = = = = = = = = = = = =
Edit - a bit later on:

To see if I could make it show itself, after Edit > Filter > Pedal Lines, in the Properties panel I scaled it up to 999% (the maximum that Custom Scale would accept) and coloured it red then zoomed in to the maximum that Dorico would do. No joy with that approach.
Next, I tried pressing alt-shift left arrow after Edit > Filter > Pedal Lines. Voilà! It showed itself. One deft press of the Delete key later, the bar became part of the multi-bar rest.
How and why it became hidden? Who knows?

2 Likes

Very interesting! Thanks for the tip! This will help, especially if I encounter this again in the future.