How do I get STEREO meter values via MIDI?


I’m making a MIDI meter bridge for Cubase 10 Pro. In the Generic Remote section I can get the meter values per channel by “Meter All”.
The values are from value 0 to 65. But it’s MONO… On a stereo track values come series, but nothing is changed if I change the pan value.
Neither can I get the Stereo Out’s stereo meter values.

Hogy could I get the STEREO meter values?


Sorry, I don’t know the reply, just an idea… Isn’t it 0-64 on the Left Channel and 65-127 on the Right Channel?

Yeah, it would be nice, but the maximum value that comes is value 65. That’s weird. Values come serial, so I can see the falling of the meter on the MIDI output. Value 0 is the lowest (infinity), value 65 is the maximal value (over +2,5dB). Logical would be 0…63 L, 64…127 R.

I tried to set the flags, but nothing changes. Neither come the values L-R-L-R, as pcm, cause the end of the falling is one single 0.


I have just tried this. You are right… What about to use Mackie protocol?

The thing is, that my controller has 32 channels, 8 group and 8 fx channels. None of the protocols can handle so many channels. HUI and Yamaha can handle only 24 tracks. Neither can I shift the channels for these protocols.


As you have 32 channels, it contains 4 MIDI Ports. So you can emulate 1 Mackie Control Pro (basic station) and 3 extensions.

How do I do that?


Just add 4 Mackie Cineol devices in the Remote Devices.

Thanks! I tried it, I added 4 Mackie Control devices, selected my MIDI output for all of them, but only the first 24 tracks are controlled.

I now have 32 channels in my project for testing. There’s a mark at the first 24 tracks that they are remoted. I can see the MIDI message if I press the Mute button for these tracks, but on the other tracks no message is sent…

I’m monitoring the MIDI output with MIDI-OX, so I can see the messages


I have just tried here on my side. It works to me. Can you see the white line over all 32 channels?

No, I can see it only on the first 24 channels.

Something’s wrong here, I deleted the 4 Mackie Control devices, added them again, and now the white line is only at 8 channels.


Do you use unique MIDI Out Ports?

No, I have a Roland OCTA-CAPTURE, I use its port.

But now, I restarted Cubase and I can see all 32 channel’s white line, and I can get the MIDI messages too! I don’t like this behavior… it was the 3rd time I restarted it, while nothing was changed.
But it seems to work, so thank you very much for your help!!


This device has only 1 MIDI port, so you cannot control 32 MIDI channels (4 MIDI Ports) by using (only) this device.

I use only 1 port for communicating. By setting the MIDI address and MIDI channel for each meter, I can transmit all the values. 16 MIDI channels, and 128 addresses per MIDI channel. One meter communicates with 2 addresses, one for Meter All, one for Meter Max(peaks).

Yeah, by using Mackie protocol metering will may not work…

By the way, it seems that the Mackie protocol uses only 12 segment, and the metering is MONO too.


That was my point.

Oh no… I was thinking it’s stereo. I’m sorry.

It’s okay with Generic Remote’s metering, having 66 different values is quite detailed, so I can adjust the threshold values on my 16-segment meters.

I’ll try the other protocols, but the best would be Generic remote if it somehow could send stereo meter values, and send the channel names via sysex.

Thanks again!