How do I load in more FX into a Channel Strip?

I’m new to Cubase, used Cakewalk 20+ years. I got a Yamaha MODX and downloaded Cubase AI 11.0.40 Build 446 (Win10)

I’m confused by how to load in additional FX into (Channel) Strip in Cubase. I fully understand what a Strip is and what it is intended to represent, it’s more a case of: the Channel Strip shows two FX modules, Comp(ressor) and EQ. To the right there’s 4 blank slots into which I am assuming I can load in 4 more VST FX. How do I do that? Could it be Cubase AI has this limited to just the two modules?

I’ve read the Manual although it’s not clear to exactly the process.


Hi and welcome to the forum,

There are no more Channel Strip modules in Cubase AI edition. But you can use any VST plug-in as an Inserts.

Thanks, I suspected that might be the case. I can now leave the Channel Strip and move on :slight_smile:

Yeah, that’s the limitation of AI version.

But you can always load Blue Cat’s PatchWork in one slot and put lots more plugins inside :wink:

And watch your CPU tank! I tried that plugin as a demo and compared it with 5 plugins to the performance of the same plugins inserted into a single track. It was over twice the burden on the poor single core to which it was attached.

Blue Cat are some amazing developers, the tools they create are really good at doing what they do, and they come up with really creative ideas. But a few of them are confusing as to why they would make them. It’s as if they are trying to build a new DAW one VST at a time. Which I suppose is one way to do it.

The other issue is the way the demos work. I would rather have it just stop working after a while, than glitch out. You can’t really test a plugin that is glitching, because it could be glitching, or it could be that what you are trying to do with it won’t work. I found out it was the later the hard way recently, and it left me feeling a bit ripped off.

They have the skills though, and a lot of their offerings are amazing.

Perhaps you had oversampling on?

With patchwork?
I think I tried with and without, but maybe you are right.