How do I record through audio interface but listen through speakers?

How do I record through my UR22 mk2 and listen through my speakers? When I select the audio interface in the studio setup menu it only allows me to listen through that as well, meaning I cant hear anything at all. And when I switch the driver to allow me to hear through my speakers, I can only record through my computer microphone.

Thanks in advance

Hi and welcome,

This is not possible. You can use only one ASIO driver at the time for both in and out.

The only one solution would be to use virtual ASIO driver ASIO4ALL if you are on Windows or to create a Aggregate Device, if you are on Mac (officially Aggregate Device is not supported by any DAW because of the sync issues).

thank you for replying Martin,

I have the virtual ASIO driver ASIO4ALL downloaded and set to my audio system on my PC, however when I go to my audio devices the only output option is still the UR22 mk2.

I see in this video explaining how to set up the audio interface in Cubase Ai, it says to connect 1/4 cables to the back of your speakers, however I don’t have those on the back of my monitors;

So I guess I’m asking if theres any other way to connect the audio to my speakers, or will I have to buy new ones with 1/4 inputs.

Thanks again


You can use a cable reduction to get what you need.

To select ASIO4ALL as an Audio Device, go to the Studio > Studio Setup > VST Audio System. Here select the ASIO driver.

Do you want record through 1st aduio interface and play through other?

In ASIO for all activate both Audio Interfaces and press F4 in Cubase, for input select 1st one. For output - another one. Works perfect. Did it hundred times.