How Do You Do A MIDI Reset In Cubase 7?

Let me start off by saying that I love the power of cubase 7 and what it can do. But I am growing increasingly frustrated with all the bugs. Most I can deal and live with as they’re minor annoyances, at least to me. But just recently I am running into a problem with stuck MIDI notes. This is happening mostly on ABSynth (almost constantly) and now my Zebra 2.

Sometimes the only thing I can figure to do to stop it is just change to another preset. But then as soon as I start playing again, it happens all over again. Eventually I hit enough keys or do something to get it to stop.

Recently I found ABSynth has a panic button. But not all synths do. Zebra does not. At least none that I can find.

So is there some kind of command or button to push inside of Cubase to send a MIDI reset or something to stop the hanging notes?

In addition to this, my Synthmaster 2.6.9 has all but stopped working. None of the dials work anymore. I can’t change volume, detune, envelope or anything that requires turning a dial. At first I suspected the DLL itself but it worked fine up until I installed Komplete 9. That’s when the bugs started getting worse.

I am getting very close to looking for another DAW, which is a shame because Cubase is amazing when it works and it took me so long to learn it I’d hate to start all over again. But I can’t continue to work like this.

I am on 7.0.5. I don’t even dare upgrade to 7.0.6 or buy 7.5 because what if the problems get worse? My business and livelihood depend on this product and I can’t afford a lengthy downtime.

Sorry about my frustration but each day this program works worse and worse. I won’t even get into the crashes for no apparent reason or loading VSTs and they simply decide to either lock up Cubase or not work.

Reaching the end of my rope. But for now, can somebody please tell me how to stop stuck notes so I can quickly go on with my work? Again, not every VST has a panic button.

Thank you.

There is a MIDI reset command - I believe it is in the MIDI menu somewhere. There are also a couple preferences to do with MIDI reset - search your manual …

One more question. Many times my MIDI keyboard will just lock up and I have to shut it down and turn it back on again. I am using an M-Audio Axiom Air 49. This in itself isn’t a big deal as it only takes a second to flip the on off switch. But the problem is, after I do that, Cubase says that it’s inactive when I go to Device Setup. Is there any way to make the Axiom active again without having to shut down Cubase and restart it? So far that’s the only thing I’ve been able to figure out to do.

midi reset is at the bottom of the midi tab menu and if you search the forum there is loads of threads on WINDOWS inability to handle "hot switching "

+1.

It is at the bottom of the ‘MIDI’ tab in the menu bar.

I use it all the time for stuck notes, resetting events etc.

Works great here but I have also read this feature may not be
as effective on a PC.

{’-’}

yer +1

So I’m guessing there’s no way to reconnect my MIDI keyboard to Cubase 7 without shutting it down when it disconnects and becomes inactive. Correct?

YES your correct

I occasionally have the same problem with a few plug-ins, incl. Steinbergs own instruments. However, if you encounter this problem constantly I think the problem might reside outside of Cubase. Midi driver, etc, etc. I can’t remember ever having this problem with Absynth. With Zebra this was one of the reported issues for a while but several updates have been issued the last year and I thought that this was solved by now. I could be wrong about this, but check that you have the latest version of Zebra (and other plug-ins). If this doesn’t help, the “old” way of fixing hanging notes in Zebra was to change the Voice Mode from poly to arp and then back to poly. Urs Heckmann and his team is an example to follow when it comes to customer service so visit the U-HE forum over at KVR and ask any question. Sorry for using this many words and still not pinpointing the final solution.

How exactly then do you troubleshoot this kind of problem to get down to the bottom of what’s causing it? Is there some kind of procedure that you can point me to? I’ll do whatever I have to in order to get this issue resolved. I just don’t know where to start.

Well, I bit the bullet and downloaded the 7.0.6 update and installed it. No changes. Still getting stuck notes on seveal VSTs.

Oddly, I don’t think this is a Cubase problem. Ever since the last Windows 7 update (for the record, I detest Microsoft) my PC has been acting strange. My mouse suddenly double clicks for no reason and that’s when the bulk of my Cubase problems started, including my Synthmaster no longer working. Oh, don’t get the VST if you’re thinking of it. I contacted support days ago and still no reply. So I’m essentially out the money I spent for the VST.

I’m hoping after the next Windows update, whatever the last one broke will be fixed. If not, I don’t know what I’ll do. It’s getting very difficult working with this program. I’m getting to the point where I’m thinking of downloading a free DAW just to see if I have the same problems. Of course I could end up with different problems that are even worse.

I’m very frustrated with this situation. If somebody could just tell me how to troubleshoot stuck note problems I’ll do the leg work. I just don’t know where to begin. Please, can somebody help me?

Okay, I am now getting stuck notes on VSTs that I never got stuck notes on before like my EWQL Solo Violin and my Sonigen Modular. This is no longer acceptable. I can’t work like this.

My setup.

Windows 7 64 bit
Cubase 7.0.6
Steinberg UR 28M
M-Audio Axiom Air 49

What do I do? What do I look at? What do I check? Do I update my MIDI drivers? How do I update my MIDI drivers? I did a search online and I can’t find anything.

If I can’t get this fixed I am going to go out of business. This is extremely serious.

Please help.

Based on what you say, your problems seem to have been caused by your latest Windows update. There is a solution to this that may or may not work (we’re talking Microsoft here!)
You can “Restore” your system to a date before your Windows update when everything was working properly. I hope you know how to do a “System Restore”. After that you will need to reinstall whatever software updates (NOT Windows) you did recently, e.g. reinstall Cubase 7.0.6. If this works, stop updating your Windows from now on.

Good luck.
P.S. Performing a virus scan is also a wise idea.

I was thinking of that but I’ve installed too much since including Komplete 9. I am NOT sitting through another 5 hours of that.

There MUST be a better solution.

I understand your frustration, but with Windows–especially when in starts to act up–you can rarely find a “better” solution.
I could suggest that you scan your system for any hardware failures ( such as a RAM module on the verge of dying–something that actually happened to me and wasted 2 days of my working time in the middle of a project) or tasks like cleaning your registry etc. But at the end of the day, you may have to format your system drive and reinstall windows and everything else from scratch. This has happened to me many times during the last 15 years or so, That’s why I switched to Mac. There is a reason why you detest microsoft. You need to be patient and try everything that comes to your mind. A System Restore definitely takes less time than starting from scratch. All in all, this is not a Cubase problem, and I’m glad you realize that. Maybe searching in Windows-related forums give you more solutions.

Good luck again.

Okay the problem has been diagnosed. It is NOT Windows. it is Cubase. I ran some of the VSTs that were giving me problems, including ABSynth which is the worst offender, in Stand alone mode. I played it for a considerable amount of time. Much longer than I would have to in Cubase before it starts to act up.

No stuck notes. Not a one.

So the problem is Cubase, period.

Now that we’ve established that, what do I do?

Done a forum search? Been covered multiple times.

Sorry if you think this doesn’t look objective but I am trying.
It does seem that you have rather a lot of very high tech spec (though I’m not sure about the computer) pieces of DAW equipment. Unfortunately this does take quite a lot of serious study to get to work reliably for months and years on end. I tend to use car analogies a lot but it’s very NOT like a car, ie; it’s not put the key in and drive off.
I would say that you are in a fairly serious knot looking at what’s happening to you and it looks like something that’s hard to pin down by any forum users. What you could do with, and I had the luxury of when I first got Cubase, is a hands on local Cubase user you can call on to help out with computer build and setup. This would get rid of more “bugs” than you’d believe possible.
First lesson you might learn from more study is to actually know what your studio does instead of what you think it does or should do. Which is usually about half of what the manufacturer SAYS it should. But that’s software for you.
OK Just reading your simultaneous post. It’s not necessarily Cubase period. Just a strong indication but, as many users have it running just fine, don’t discount anything.
Could be something about your computer. More likely to a conflict between Cubase and one or more of the programs you ran stand-alone but which one’s faulty may take a bit of tracking.
I’d never say I’d definitely “diagnosed” a problem with Cubase and any computer. I’ve been at it too long.

First uncheck your midi sysex filter in Cubase Preferences then see what happens. Check any other midi settings that look viable there. It looks like your midi flow is being interrupted somewhere and you’re losing your “note off” command. This normally means too much midi is going down the pipe or that the pipe is too small or blocked. Before the i3/5/7 intel computers this used to be a motherboard regular offender.
The flow could also be interfered with by a software setting which could be Cubase. I’m assuming here that your computer is adequate for the job (by “3” I guess that means “i3” which I’d call a bit on the cusp as I’d prefer an i5 at least but i7 for preference which I do) but only you know that for sure. Sorry I can’t think of much more for now but if your experiences are anything like mine the solution will usually come from somewhere you never thought of looking. :mrgreen:

You might get rid of a few problems, especially after a large download and installation of several big programs that put files all over the place, of doing a maintenance defrag. If you use a stock laptop and use large sample libraries put these onto a fast external drive. Again defrag that drive after installation.

ps: check that you’re not using “All midi inputs”.

@Buchanan

Thank you so much for the detailed response. You can’t imagine how much I appreciated it. I checked off the sysex boxes and, at least for now, it seems to have done the trick.

My question is, why? What does sysex have to do with stuck MIDI notes?

My PC is fairly powerful at a core 3, 16 gig ram. It should handle what I’m trying to do and as far as streaming massive libraries like EWQL and the new Komplete stuff, it’s been doing fine. For the most part, Cubase works fine. But the stuck notes and the several crashes per day (usually from older VSTs, even though I do have them bridged with Jbridger) get annoying. The stuck notes have been awful of late. Don’t understand why. I’m actually wondering if it’s since I updated to 7.0.5. Because I didn’t have this problem when I first installed the software.

Just so you know, I’m an old timer. Started before MIDI even existed with old Moog and ARP synths. I go back to the late 70s with gear. I can even program modular synthesizers. That’s why this problem is so frustrating for me. I’ve never had these issues in 35 years. Not even with my first MIDI synth which was a Yamaha DX7.

Anyway, thank you again for the assistance. Turns out it was Cubase, albeit a setting that I still don’t understand why it would cause stuck notes.

I’ll keep an eye on it to see if the problem returns. I’ve learned from experience that things can break for no reason at all.

One other thing. I see that All MIDI Inputs is the default. What do I change this to? Do I have to change it each time I bring up a VST?