How Do You Do This Routing In Cubase 7?

This video will show what’s going on better than I can possibly explain it.

https://www.youtube.com/watch?v=bUTy4qp95Cw

TLDW (too long didn’t watch) - Essentially he’s got a sequencer loaded into Reaktor and he’s got the sequencer outputs going to 3 separate vsts outside of Reaktor. He’s doing this in Logic and doesn’t explain how the synths have to be setup other than they each have to be on different channels. If you listen, each sequencer pattern (main, P1 and P2) is being routed to each of the different vsts.

How do I do this in Cubase? I don’t even know where to begin.

Thanks.

PS - Most amazing sequencer I’ve ever seen in my life.

listen to the first minute of his video and you will notice he says he is using a standalone version of reaktor that is being routed into a DAW. You will need an advanced virtual midi configuration installed within your OS-system to be recognized by the daw to route it as multiple midi in’s for the daw who is hosting the plugins. This is a very complex way of having a workflow in a computer.

Type in google virtual midi cable and select one that is suitable for your OS. That should make it possible for you to match the explained setup. I.e. reaktor as a standalone synth, routing midi to the DAW.

This looks indeed nice once it is being setup, and probably this is a case example made by the guy who made the ensemble for reaktor. Reaktor is a tool where people can design their own interfaces. I guess this is one of them, and probably on of the more advanced/complex.

But all i can say in this post is that this is a complex workflow that can’t be explained in a few words.
Only that once you have virtual midi-cables, you then can insert them as midi-inputs in to any DAW.

kind regards,
R

Let me ask you this. Let’s take a simpler example because I can’t even get one Reaktor 5 sequencer and VST to work.

How do I setup a Reaktor sequencer (any sequencer) to transmit it’s MIDI data to any VST in Cubase? I tried setting it up as a group channel the way I did with Glitch as an FX insert but it doesn’t work.

This should be a very basic function of sending sequencer output to VST input.

You have to have a Reaktor ensemble that outputs midi. Not all do without being tweaked. Then enable midi out on the reaktor instrument track. Now on the track with the Vst you should be able to select Reaktor as the midi input

Hi There

As JMCecil says, load Reaktor as an instrument, the ensemble in question should have midi out enabled (I just tried it with the Node1 ensemble so it does work) then on whatever, and however many, midi or instrument tracks you setup you choose “Reaktor5-MIDI Out” as the input.

Best Regards

Dave

Where do you enable MIDI out? I don’t see any option to do this for any instrument VST. That’s my problem. I don’t know how to do an “enable MIDI out”

Short answer: In the Inspector pane (on the track with the synth you want to control) there is an “Input Routing” drop down. You’ll select it there. And make sure to enable the “monitor” button on the synth’s track, or you won’t see (or hear) the midi data coming in to it.

Long, detailed answer:

It works, I just tested it with a user-created ensemble called “midi2seq.ens” – I don’t remember what it does, or where I got it, but when run it produces midi note data.

You’ll know when a Reaktor ensemble does this because it lights up its little “midi out” light in the upper right side above “osc” and just to the left of the Reaktor cpu meter.

Start there, with an ensemble that at least is doing this.

Next step is choose Reaktor’s midi out as the input to another synth (preferably a synth with a keyboard display so that you can see the notes being played, visually).

Go to the other synth in the arrange window’s “Inspector” and in the top pane right above the VSTi instrument selection drop-down (where you see your synth’s name) is “Input Routing” – this is where you’ll select “Reaktor5-MIDI Out” as the input to the synth.

You should immediately start seeing the orange “Event Received Indicator” light up from all the midi data being sent to it, see the synth’s keyboard being played and hear the sound.

Again, make sure the Reaktor ensemble is, in fact, sending out midi. If the Reaktor “midi” (out) light is not flashing/flickering/lighting up, it’s not sending anything out.

I’m almost there but I must be looking in the wrong place to select “Reaktor5-MIDI Out” as the input to the synth. The only options I see (where I am looking) are the following:

Axiom Air 49 MIDI In
Axiom Air 49 Hyper Control
Axiom Air 49 Ext MIDI In

2-Axiom Air 49 MIDI In
2-Axiom Air 49 Hyper Control
2-Axiom Air 49 Ext MIDI In

Here is what I did so far.

Opened up Reaktor as one VST instrument. Inserted Spiral.ens. Enabled MIDI out to plugin.
Opened up Zebra 2 as another VST instrument. Put monitor on.

Went back to Reaktor lane. Opened Reaktor. Made sure when I played a note the MIDI light came on (it did). I also heard the Zebra init patch sound when I struck a note. So MIDI data is going from Reaktor through to Zebra when I play a note.

However, when I run Cubase (play mode) the sequencer doesn’t trigger Zebra 2.

So I then went to this next step.

Go to the other synth in the arrange window’s “Inspector” and in the top pane right above the VSTi instrument selection drop-down (where you see your synth’s name) is “Input Routing” – this is where you’ll select “Reaktor5-MIDI Out” as the input to the synth.

When I did this (I think I’m in the right place) again, all I saw are the options I listed.

Please confirm that I am at the right place. I am at the far left hand side of Cubase where it has the name of the VST at the top of the column (Zebra 2), underneath that are the M and S for mute and solo, and so on down the lane until I get to the line that reads when I mouse over “Input Routing (All Selected With…)”

If that’s the right place, Reaktor does not show up as an input option.

What am I doing wrong? Is this something that is only available in Cubase 7.5? (I am running 7.06)

I am at the end of my rope with this.

Okay, I figured out what I have to do to get this to work. I have to use the VST Instruments rack in order for Reaktor5 to be enabled as an input option.

Now I have another problem. When I stop the sequencer (by stopping the Cubase play button) the sequencer stops sending MIDI data but the last note received by the VST instrument (I am using Zebra 2 for the test) gets stuck and I have to do a MIDI reset.

I’m going to try this with other instruments to see if it’s specific to Zebra 2 or a problem within Cubase 7 itself regardless of the instrument chosen. If it turns out to be the latter, how do I resolve this?

** EDIT ** The stuck note problem appears to be sequencer specific and not VST specific. Interesting. Anyway, at least I have something to work with now. I can work out the minor bugs as I go along.

Did not know that choosing “Project - Add Track - Instrument” and “Devices - VST Instruments” gives you two completely different operation options. You can’t choose the input of one VST to drive another VST with the former. Only the latter.

Yes, you’re in the right place. It should be showing there.

It’s not a 7.5 feature, v7 and even much earlier versions are fine.

Very strange, Reaktor’s working for me, in the way we’re wanting here, as a Track Instrument, as well. I’m not sure if that part is a 7.5 thing. Perhaps someone else can confirm.

Hmm, don’t know about the stuck notes.

You might try using the MIDI Inserts panel (in the Inspector) on the track with the synth you’re controlling.

Start with a MIDI Monitor, so that you can see what exactly is being sent from Reaktor.

Some of the other real-time MIDI inserts may be of use in even catching, filtering or transforming the MIDI in a way that could solve the problem. Maybe (it might be worth looking into).

Glad you got it mostly working.