How to bypass MIDI Remote to record normal MIDI data

I really like all the new MIDI remote feature, but how can I bypass it so I can still record normal MIDI CC messages?

Disabling the script in the MIDI Remote Manager works but it’s really, really inconvenient.

I tried mapping the Track QC to the CC(s) I want, but this records it as automation not as MIDI data.

Am I missing something?

1 Like

Please open the MIDI Remote Manager, go to the Scripts tab, select the device and hit the “Disable Controller Script” Button. That’s it.

Thanks, but as I mentioned, doing that is extremely inconvenient. I need somehow to be able to quickly switch back and forth. A bypass toggle or a shortcut would do, but not going into the Remote Manager.

I tried creating a page that maps to nothing, but MID Remote still captures the controls and does not allow me to send any CC anymore.

That’s true. You have to leave those buttons/knobs/faders out of your custom surface. Please create only those elements that do not send messages you need to forward to the track.

But then I can barely use my controller
If I want to map the pads to anything, I cannot use the pads anymore.
The default behavior should be that it should not capture the messages if the controls are unmapped, that way we can at least create a page for normal MIDI messages.

1 Like

I agree with you. Will make a bug report (to myself and fix it then :wink: )

6 Likes

Thanks for posting this @arieln! I had the same thoughts.

A shortcut to quickly disable/bypass the entire Controller Script to switch back and forth would be really useful to many, I think.

All the best

1 Like

Yep. One line in preferences would be enought. Key command or even assign a hardware button to it. Back and forth, back and forth. Good idea.

Just in case it’s helpful to anyone coming here, since the last 12.0.20 update, it’s possible to create a page mapped to nothing, that will effectively let MIDI messages go trough.

That’s probably as good, or even better than enabling / disabling MIDI Remote.

2 Likes

Exactly!
I was just about to write about it. Just checked. It works.

I rewrote the script. Added a blank mapping page right into it. Assigned a button on the controller that changes pages.
At the same time, I had to make a new sysex dump so that the controllers switch to absolute mode instead of relative. The dump is sent when the page is changed. Works great.

Yes, totally agree: a single “bypass” button for MIDI Controller Scripts in the MIDI Remote that can be set to a keyboard command would be wonderful. Please do make this happen, and hopefully soon!

This gets in the way of being able to control certain MIDI hardware and is pretty annoying.
Also, an indicator of some kind on the bars at the top or bottom of the screen that could be optionally added would be wonderful.

I jump from hardware to software instruments quite a bit in my workflow. Thanks!

I’m having a similar issue, but different. I have a nano Kontrol which has CC’s mapped to it, CC1,CC11,CC2,CC7, and it works great in cubase 11. But if I open Cubase 13, which has the Midi remote manager, it hijacks the NanoKontrol and restores all the CC data back to factory. Then if I delete the script, the CC’s remain factory reset.

Is there a way to tell Cubase NEVER to auto map this device? Just leave it alone permanently? Or at the very least a way to keep CUbase from reverting it back to factory settings?

Thanks!

I have the exact same problem when connecting nanoKONTROL2 with cubase. It is happening only when I use MIDI Remote. I have to open the nanokontrol editor everytime after launching cubase and change the CC assignments as the midi remote script reset the sliders to the factory default on startup.