How to deactivate "for grouping only" for one bar only

You will see here in my score that the 8th notes have been grouped by using the “Edit time signature” dialog set to 2 + 2. It works ok but now my last bar is also divided into two half notes. How can I leave the last bar as 1 whole note?

The easiest way is to use the Cut Notes tool in the middle of the two tied half notes.
Another solution is to insert a new time signature in the last bar and hide it.

If I apply the cutting tool in the middle of the two notes, I get the following result:

On the other hand, if I click on the first half note with the cutter, it works for me:

Actually it depends on the quantize settings. The smaller the quantize value the closer to the first note you will have to apply the Cut Tool to get that result.

the Mouse Position on the status line updates in real time. thereby, one is able to know where they are clicking.