How to delete notes/rests when there are too many in a measure

After importing a musicXML file I get a whole bunch of measures that have too many elements in them. I tried to correct that, but can’t get it done somehow.
Selecting the rest in the measure and pressing Del, CTRL-Del, BackSpace, CTRL-X all don’t work, the overcomplete rest is staying where it is. Also changing voices (with the V key) does not help…

Something similar in post: /too-many-rests-in-measure/765847
But the solution there eludes me. (not allowed links, dunno how to point to other posts)

Can someone dummy-explain it to me ? I’m just starting out on this Dorico Elements trial version :smiley:


Presumably the MusicXML file you imported is set up incorrectly, with extra hidden rests and things lurking around.

You’ll need to do this fix in two steps: remove the extra rests that are upsetting the flow of the music; and ensure that the bars are actually the right length. It doesn’t matter which order you do this in.

To remove the spurious rests, select the rest whose time you need to eliminate, then type Shift+B to open the bars and barlines popover. Enter a string of the form -1q that describes the amount of time you want to remove: q for quarter, e for eighth, h for half note, w for whole note. You can use decimal values, so e.g. -1.5q will remove a dotted quarter (and so will -3e of course). Go through the flow closing up these gaps in this way.

Now you’ll have music that sounds right, but the barlines will all be in the wrong place. Provided the music doesn’t change meter all the time, the simplest way to fix this is to select the whole flow (Edit > Select All), then select all the time signatures (Edit > Filter > Time Signatures) and hit Delete. Then simply recreate the initial time signature at the start of the flow.

1 Like

Thanks :slight_smile:
However this is very time consuming :cry:
I’d better start entering the notes from scratch.

It seems Dorico has a rather steep learning curve :face_with_diagonal_mouth:

It shouldn’t be too time-consuming. But it would obviously be better to start with a MusicXML file that doesn’t have these kinds of errors in it!

1 Like

Ha, so true, but this musicXML was created by digitizing sheet music with ScanScore.

The entire piece is around 900 bars (82 pages) so I have my work cut out for me :crazy_face:
Scanning in and digitizing the sheet music is not the best way forward it seems :pensive:

That is no guarantee. You will read many, many threads here about xml transfer problems to/from many different reputable programs.

I’m not sure if it will make a difference with this particular file, but have you tried changing the XML import settings (Edit>Preferences>MusicXML Import)? Uncheck all options and try the import again.