How to freeze Kontakt-based tracks?

I’m new to Cubase as of a couple months ago. I’m working on a song with only about seven tracks on it. I’m also on a performance gaming rig with an i7 4960X 3.6GHz and 64GB of RAM, as well as the latest WD Black performance hard drives.

I’m noticing that if I enable record on a track at this point, playback (not even recording, but playback) will pause unexpectedly and resume, rinse, repeat.

I’ve frozen everything I can see to freeze in terms of instrument and audio tracks.

I do have several tracks which are based in Kontakt. However, neither the MIDI tracks controlling the parts, nor the audio output tracks for those parts have a freeze option.

Is there any way to lighten the CPU load by freezing/bouncing those Kontakt-based tracks? (Bounce is apparently only for audio and instrument, which makes no sense to me, given how Kontakt is handled. You should be able to freeze a track from a multi-timbral instrument like Kontakt or Addictive Drums.

I’d swear there’s a way, but if there is, I’m not seeing it.

Please help? Thanks!

(Also, why does having record enabled suck that much more CPU? If record is disabled everywhere, it’s fine. I have been very impressed with Cubase Pro until starting to run into some limitations I’d have expected with FL Studio, rather than the flagship standard DAW.)

Someone on Reddit helped me. Apparently you freeze these in the Rack, rather than the Playlist track list. Same mechanism, different area of the UI.

Thank goodness there’s actually a way.

I have to say, though, the CPU usage meter is -way- off. It still looks like I have 30-40% free when it starts pulling this nonsense. I think they need to re-code that meter, because it’s obviously inaccurate.

Several things.

What you are seeing is not typical behavior. You shouldn’t get a pause on record enable. Seven Kontakt Tracks is not a big load & should easily run on your system.

Are you sure you are running out of CPU? I’d suspect something else is involved, but…? Does Windows’ Performance Monitor show CPU maxing out? The meter in Cubase isn’t really a CPU meter, it is a VST performance meter which is supposed to take into account all the various resources needed by the VST Engine, that said CPU is probably the biggest component.

Do you by chance have multi-core turned on in both Cubase & Kontakt? If so turn it off in Kontakt - you only want one chef in the kitchen.

You might also play around with the buffer settings on you audio interface (I’m not a expert on this but others here are that hopefully will be more specific). Also what is your audio interface (we encourage folks to put sys specs in sig so we don’t need to ask - hint, hint :wink: )?

FYI, Instrument Tracks fully support multi-temporal VSTi’s. Search the forum for several detailed threads on using MIDI vs. Instrument Tracks.

I know Kontakt is set to multi-threading. If Cubase is as well, I could turn it off in Kontakt.

No, that’s the bizarre thing regarding the CPU, is that I looked at Iarsn TaskInfo (better than plain Task Manager), expecting to see spikes, and there’s…nothing. There’s -plenty- of headroom on all cores when this occurs.

I mean, I do have like four instances of Neutron running, but still, the raw CPU load is nowhere near maxing.

Good to know about the meter, although something is a bit odd somewhere if I’m hitting this weirdness.

I’m not -strictly- using Kontakt on this track. My tracks:

  1. Time signature track.
  2. Original song imported from MP3. (I’m almost done with my cover of it).
  3. Tempo track. (Currently disabled, and everything is hardwired to 62bpm.)
  4. My vocal track. Imported pre-cleaned WAV (RX5 before import). Inserts: iZotope Nectar 2, iZotope Imager, iZotope Vintage Limiter, iZotope Neutron.
  5. Spectrasonics OmniSphere using a single patch for a pad. Inserts: iZotope Neutron.
  6. Spectrasonics Keyscape with a single layer of the Yamaha C7 grand piano. Inserts: SandMan Pro, iZotope Neutron.
  7. Kontakt with currently two instruments:
    6a) Orange Tree Evolution Steel Strings guitar. Inserts: iZotope Neutron.
    6b) Factory violin. Inserts: iZotop Neutron.
  8. XLN Addictive Drums 2. I have the kick routed to a separate out with no inserts. The main out inserts: SandMan Pro, iZotope Neutron.

I also have iZotope Ozone 7 on the master stereo out.

That meter still had plenty of headroom left, and my CPU cores as I said had tonnes of headroom as well. RAM isn’t even an issue with 45.9GB free yet.

Neutron isn’t as hungry as you’d think. Ozone is far needier, by comparison. The delays from SandMan would be the worst of it, and those aren’t even that crazy.

If you see anything out of place, let me know. I’ll try turning off the Kontakt multi-core.

I tried disabling Kontakt multi-core support. No joy. I see no place to turn off/on multi-core support in Cubase, either, and the manual doesn’t seem to indicate one.

While searching for such a beast, I enabled Cubase warnings on CPU overruns, and it swears there are overruns. I get the dialog the second I simply enable recording on any channel. Not actually -start- recording, but simply enable recording on the track.

Here’s a link to a screenshot of TaskInfo showing all my cores at the time I was letting this happen (it was doing fits and starts the whole while, and if you dismiss the overrun alert box, it comes right back):

Please show me a core above 26% usage. I’ve gone over the cores in that screenshot several times. That was taken -while- it was exhibiting. I took another screenshot during the tail end of a previous attempt, and the highest core was still only 55% in use. Like I said, -plenty- of headroom on all cores.

If you don’t trust TaskInfo (their graphs always look worse than the numbers for some reason), here’s Windows’ own Task Manager (the official built-in) performance graph screen. I again forced it to do the same thing by enabling record on a track, and again I got the dialog boxes about Plugin Overuse, and took this screenshot right as it was allegedly happening:

I’m not seeing the issue, but it’s indeed happening, and Cubase believes it’s plugin overuse and reports it as such if I enable the feature.

What do you think? I’m glad to hear it’s not normal and you believe I should have no problems with what I’m doing (which is honestly pretty simplistic compared to some things I’ve done in FL Studio, as I usually run more generators there because I pretty much only ever bounce anything if I’m using IronAxe because that beast is CPU-hungry).

So, how do we fix this? I’m all ears!

Sounds more like an ASIO overload, like raino mentioned, try increasing your buffer.
Devices > Device Setup… > VST Audio System (whatever you have)

Bingo. Bumped ASIO4ALL from 64 to 256, and that appears to have stopped the issue.

Bit of a misnomer that it reports it as a plugin issue, rather than a driver overrun issue. I’m used to FL Studio reporting them separately. Don’t get me wrong…I -love- Cubase Pro, and I’m transitioning to it. I actually prefer it so far (after about 6-7 years of FL Studio!). I’m just used to a separation of reporting in this area.

Thank you both so much for helping me put this to bed!

Ah, glad to hear it got sorted out. DAW performance issues can be hard to find since they use computer resources in a pretty unique manner.

To clarify the above you want multi-core on for Cubase & off for Kontakt.

Thanks! Yeah, I’m much-relieved!

Where is it turned on in Cubase? I went over the VST-related pages three times and did not see anything of the sort. I didn’t under General, either.

I noticed no difference with it on or off inside Kontakt, honestly.

It’s always on in Cubase, I should have been clear about that. Often having it on in Kontakt will work fine until you start consuming more CPU.

Imagine a street intersection where there are 2 traffic lights installed that each turn red & green totally independent of each other. If you don’t have much traffic on the two streets there is a good chance it will work out OK. But as the traffic increases problems will occur as different cars follow different signals.