How to get M audio midi controller to contol transport panel functions

I have an M audio 49 key midi controller which has a slider and some transport keys on the top left hand side. I wanted to assign these to the transport panel functions so I did some searching and saw that the way to do this is via the “generic remote” section in the “device setup” section. However when I create a generic remote and check the “learn” box, cubase does not recognize the transport panel keys so I am unable to assign commands to these buttons. The normal keys and the volume slider are recognized but not the transport buttons. In the M audio manual it says that the keyboard uses Midi, HUI or Mackie controls to send this data so I am not sure where the problem can be.

Can anyone please help?

Hi,

Make sure you have the MIDI INput port selected, please. Then click Apply to confirm the MIDI Port. Then you should be able to Learn.

Hi Martin. Thanks for the reply. I use USB for the midi data and as you can see in the image, the ports seem to be connected. For some reason the Maudio has two different midi connections (USB MIDI) and (TRANSPORT). I don’t know why there are two but both seem to be connected.

Furthermore, the transport buttons are able to learn in the VST Quick controls section. They do not work in the Generic remote section or the Track quick controls section.

Please can you help?

I don’t want to be a downer but I had exactly that controller and sold it because it just wouldn’t work with Cubase no matter what I tried. I hope you have better luck than me.

Got a couple of Nektars now which work perfectly.

Hi,

Could you attach the screenshot of the Generic Remote Device, please?

Aloha attaboy,

As an old ‘MIDIot’ here this thread intrigues me.
Don’t know about specific pieces of gear (m-audio) but just talking in the MIDI protocol:

Years ago I used a MIDI guitar set-up live on stage and I was able to send a MIDI ‘stop/start’
command from my guitar controller (Roland GR-50) to a MIDI sequencer
(Roland MC-50) to ‘start’ the next track.

I programmed the controller so when I played the guitar’s highest note, (C#)
the command would be sent.

In my situation I did not need the other transport commands (rewind /fast forward etc)
on stage but the stop/start command worked just fine to start a track.

Of course I had to not play that note during the song but other that that, all worked well.

Once I started using a laptop on stage there was no need for that procedure
so I forgot all about it.

It has been sooo long ago I do not remember the specific ‘Stop/Start’ MIDI control #
but I am sure you can find it and perhaps then you can program your m-audio
device to do something similar.

Also, it may not be possible via MIDI to have FULL transport control,
but maybe it is and it’s a place to start to try to solve your issue.

Hey attaboy, this advice may be totally off base so I’m sending you a
'forward ‘ma bad’ if this info is useless to you.

HTH
{’-’}

Yes sure, here is a screenshot

thanks for your help

Hi,

I would recommend to set the MIDI Output to Not Connected. And I can see the Lear is not enabled.

When you hit some button on the MIDI Keyboard, can you see incoming activity on the Cubases’ Transport Panel, please?

I do set the output to “not connected”. And I did check the learn box too when I tried doing this of course. When I push the transport buttons on the midi controller I can see in my cubase transport panel that the midi message is coming through to the Daw but not in the Generic device section.

Also, I did mention that the learn function does work with the transport buttons on the m audio controller in the VST quick control section. You did see that right?

Hi,

Could you just record the MIDI Messages, to know, what MIDI Messages these are and enter them manually to the Generic Remote Device?

Do you mean to record midi data as if I was playing the keyboard while recording? When I do that, nothing is recorded.

Hi Martin. Like I told you, in the VST quick controls I can see that the transport buttons do work so I am able to see the address of each button. I wrote down the midi address of each button and went over to Generic Remote and then input manually like you said. Here is a screenshot of the first three buttons. I am sending you a picture because maybe you can see if I am doing something wrong. It is still not working.

Hi,

The settings seems to be totally OK.

Could you try in Cubase Safe Start Mode [Disable preferences], please? Then set the Generic Remote Device (still running Cubase in the Safe Start Mode). Does it work?

Hi Martin. Thank you. I tried what you said and it seems to work now. Can you please tell me what this means and what I should do next?

Hi,

That means some preferences was corrupted. Once you Delete the Preferences, you get factory settings.

I’d add a Mackie via the + button and choose the transport port as input

Wow, that was some troubleshooting session. Thanks a lot for your help Martin.

One more thing. Do you have any idea why Cubase recognizes two versions of the midi controller? I see m audi (USB MIDI) and (Transport). What is the difference between the two?

Hi,

I don’t know. The driver is provided by system and the system takes it from the device. I would have a look to the user guide.

If you set up the keyboard to use Mackie (or HUI) messages for transport, those messages use the -surprise- ‘Transport’ port. You would have to choose this port as input in the remote set up window (see my previous post).

If you wanna try this out, don’t forget to exclude the Transport port from ‘All MIDI Inputs’! Otherwise you will get unwanted notes every time you move around if you use the ‘All MIDI Input’ as input port on your VSTi.