How to hide empty staves?

Hello!

Can someone tell me how to hide empty Staves, for example when writing for choir?
And how about using something like Uservoice, so we can provide feature requests?
Btw. I cant wait to use Dorico as full replacement for my Sibelius :slight_smile:

The options for hiding empty staves are on the Vertical Spacing page of Layout Options.

But this option does not hide empty staff if only the top or bottom staff of a two-staff System is empty.

I have the same question. I imported a piano piece using MusicXML and there is an extra empty staff above the normal two staves which I cannot figure out how to get rid of or hide. I think it is because I had an ossia bar in Sibelius which creates a hidden staff above the entire piece. I tried hiding empty staves on the vertical spacing page of layout options, but there was no effect.

Liamk, try deleting the very initial clef at the start of the empty staff, and that might cause it to be hidden as you would expect.

We don’t currently allow only one of the staves of a keyboard instrument to be hidden, but although this is almost never done in orchestral music, it’s obviously done in some other circumstances, so we should add an option to allow it.

I finally found a solution, which was to delete the unwanted third staff in Sibelius before exporting to MusicXML. I tried deleting the clef at the beginning of the empty staff, both before and after selecting Hide Empty Staves in Layout Options, to no effect. Both times, when I clicked on the clef in Write mode, the clef was highlighted, and then after I pressed delete, I could no longer highlight it, but it was still there and the staff was still shown for the entire piece.

Is it now possible to hide the lower staff in a piano score, if nothing is written there? It can save me at lot of space when printing. Very easy to do in Sibelius…

Yes, you can switch on the ‘Allow individual staves of multi-staff instruments to be hidden’ option on the Vertical Spacing page of Layout Options.

I haven’t been able to hide the empty staves in the first system, despite all my efforts - any solutions to that?

Try deleting the first clefs

Hi there! It’s a year later but I have a similar question!

I have a piece for choir and piano. For the choir I’ve used a choir (reduction) staff - SA (treble clef staff) TB (bass clef staff). The piano plays throughout. The choir sometimes sings SATB (both staves) and sometimes just SA (the treble staff). I want to hide the TB or bass clef staff when it is empty.

In Layout Options under Vertical spacing I’ve selected HIDE EMPTY STAVES / ALL SYSTEMS
I’ve also checked the box ALLOW INDIVIDUAL STAVES OF MULTI-STAFF INSTRUMENTS TO BE HIDDEN
no players are excluded from HIDE EMPTY STAVES

However the empty TB line (bass clef) still shows throughout. Is it not possible to hide it?

David, are you sure that staff is completely empty in the systems you’re trying to hide?

Is this a new project, or an XML import?

Yes they are empty. And it’s a native Dorico project.

When both choir staves are empty they are both correctly hidden. However, when the tenors and basses have rests for 20 bars, they still show. This is the case in the full score and in the layouts.

Did you try right-clicking (in Write Mode) on the staff and choosing “Remove Staff”?

  • D.D.

Yes! But then the bass clef staff disappears throughout the entire flow, including the bars where there is music to sing. Perhaps the multi-staff choir staves cannot be hidden independently?

To get the staff back again, right-click on the SA staff and select Staff / Add staff below. Dorico will re-use the staff that used to be there, not create a new one.

If you “remove” a staff that has music on it, the music isn’t deleted - it will reappear if you display the staff again.

OK I did that. But I get this error message . . .
Screen Shot 2018-11-07 at 5.54.13 PM.png
I suspect this happens because when I created the choir staff I did it under ADD SECTION PLAYER / CHOIR REDUCTION

If I created another choir reduction under solo player, and copy and pasted the part, would that work? But choristers are section players no?

Yes, that should work. Just don’t lose any sleep about your choristers being section players. All this is a workround for the real problem about hiding empty staves (and I don’t understand why that didn’t work, I think it should have done).

“Choir reduction” needs to be added as a solo player, NOT a section player. Then hiding staves works as it should. No need for workarounds with adding and removing staves in this case, thankfully!