How to hide Sustain pedal data in Midi Editor (piano roll view)

Hi all,

Is someone knows how to remove the CC64 (sustain pedal) information on the piano roll ??
Just want to see my note data (piano arpeggio) in the upper section + on/off pedal on the lower section. Not both on the upper section :angry:

I know it’s possible to use Midi / Function / Pedals to note lenght, but not satisfaying for me…

Thanks all ! :wink:
Capture.PNG

you can goto midi list and see the data cc64 there and delete it.

Hum, if I delete the data CC64, thn my sustain pedal is removed too.
I only want “clean” the piano roll screen and hide CC64.

– edited title, was confusing–

If you want to keep the Sustain data but not see it, go to where that Lane is labeled “Sustain” near the lower left. You can select this and change it to display another parameter like Velocity, or set it to no Lane at all (or even display multiple Lanes).

Thanks Raino but the problem is not the controller lane view. Here, all is ok.

The problem is on the piano roll itself.
I see the played note (on/off) + the sustained note. I would like only the played note, without the sustain indication.

PS : I’m not at home, maybe if I hide the controller lane, then the sustained note will dissapear also…maybe that was the sens of your answer. Will check tonight !

Oh, I see now. That is weird. I’d want to hide it too. Not seeing it here, just did a test to make sure. A quick look at preferences & toolbar buttons didn’t turn up anything obvious.

This looks like Note Expression data to me - although I’ve never used it so I’m no expert!

You can hide note expression, there’s a button in the toolbar at the top of the Piano Roll. It looks like you’ve got the button hidden so right click on the toolbar and select Show Note Expression Data. Then you can click the new button to show/hide the dots.

But, I wonder why you’ve got note expression data as well as the controller lane? I thought it was either one or t’other - otherwise you would get two sustain messages and they may conflict if you edit them differently…

Mike.

I don’t think so. I do use Note Expression on occasion and have never seen a display like that. Plus Notes with Note Expression have a little icon at the very end that looks like 2 triangles. Can’t be certain but the screen shot doesn’t look like the icon is there.

Yes, it’s definitely Note Expression. For my own benefit - to confirm to myself and to learn something about note expression - I recreated the image by creating arpeggios with sustains and then I ran Midi->NoteExpression->ConvertToNoteExpression on the midi part and it is the same. So, as explanation, see my image below.

Ring 1 - The ShowNoteExpressionData button - show and hide
Ring 2 - In fact the Sustain events are converted into note Release Lengths (and the sustain data isn’t deleted, whereas it is for other controllers)
Ring 3 - I reduced the Release Length on this selected midi note - you can remove the ‘sustain’ tail entirely by setting this to zero

Two ways to answer the OP’s question:

  1. Select all notes and then change Release Length to Zero (double-click in release length so you have all text selected then type 0 and press Ctrl-Enter to set all values absolutely zero (rather than relatively, which is what happens if you don’t press Ctrl))

  2. Hide the Note Expression Data using the show/hide button.

Mike.

Thanks. Very informative.

Thanks for this answer, GargoyleStudio. But I’m still a little confused. I’ve used Note Expression in the past, but not for some time. On tracks that this “problem” occurs on, “Record MIDI Controllers as Note Expression” is NOT turned on. So, how did the Sustain controller get recorded as Note Expression in the first place?

Strange. Maybe you’ve found a bug? Or there’s some other settings at work here. If you can find some steps to make this happen then you could raise a post in the Issues forum.

Mike.