How to integrate Transport on Kontrol A49

I have a brand new Kontrol A49, but I can’t make the Transport buttons work in Cubase.
Looking in Studio Setup -> Remote Devices -> Generic Remote I’ve set both in and out to Komplete Kontrol A49 Midi. A whole list of controllers is shown, but no Transport stuff.
I can only find video’s with the Kontrol S-series and an older Cubase version which still has Devices in the menu. There it seems to go smoothly but I must be doing something very wrong. Help would be appreciated.

Im not familiar with the NI controllers.
There might be some tips in the Kontrol A49 manual, how to best use it with Cubase?

For generic remote.

In the upper window.
-First you need to add how many buttons you need.
-Name them if you like.
-Learn the buttons. Activate the learn. Assigning the control.
-Make shure the controls are set to Note ON.
-Set the flags. So cubase recives the control message and cubase can transmit message to the control (If you have led lights on the buttons, this can be handy).

In the lower window.
-Set device to transport
-Set category to devices
-Now you will find all the transport goodies.
-It depends a bit on your controller type/mode, if you need flags here. I dont think you need any flags since it is transport.

Here is a photo of my transport setup (Just ignore the rest of the controls).

Thank you Reflection for taking the time. However, I can’t make heads or tails of your how-to.
Pressing Add doesn’t do anything.
I can’t make it learn anything as (for example) pushing the start button on Kontrol is not registered in Cubase.
NI says that it should be simple and automatic: https://support.native-instruments.com/hc/en-us/articles/209557849-Setting-Up-Steinberg-Cubase-Artist-Pro-or-Nuendo-for-KOMPLETE-KONTROL
Well, seems to be primarily an NI thing so I’ll go to their forum.

Ok.

Think that is the best thing to do too.

Also here is a video I made for helping out a forum meber, setting up QC with generic remote.
https://youtu.be/WXam6z_fUo4
It shows the setup process, for the upper window.

Reflection, I found your video enlightening. I’m not sure though what I should choose in the 2nd column of the top window (midi status). Controller? Note On? Remember, I’m trying to assign transport buttons. Also, looking at your video it seems that one has to turn on Learn, choose the fourth column (Adress) and then push the button one wants. However, pushing the play-button on the Kontrol isn’t registered.

NI forum is way slower in answering than here :frowning:

KOMPLETE KONTROL keyboards work with all DAWs that support VST/AU/AAX, with additional features enabled in Logic Pro X and GarageBand at launch.
Ableton Live, > Cubase, and Nuendo integration coming soon after initial release> . Using an integrated DAW will allow you to play/pause, record, set tempo, adjust levels, quantize notes, adjust loop braces, undo/redo, and more – all from your keyboard.

So that might be it? It simply doesn’t work YET? Fingers crossed.
Thanks, Grim.

On the second column you want to have note on.

When you are in learn mode. You just need to select the controller you want the button assigned too, press it and move on to the next one.
If the controller dosent registered, try hitting apply in the lower screen and try again.

And as Grim posted, there is some integration software in the works. So thats a good thing :slight_smile:

Here https://youtu.be/lyZMoVD-Rys

I made a quick video of setting up Transport.
Sorry for the chewing and low mic quality. WebCam mic is not the best :laughing:

The rest is just making sure your A49 is setup correct on midi and transmit midi.
And remeber to export the setup, if you get it working. So it is saved.

Hope the dedicated integration is not far away. :slight_smile:

Reflection, you’re a hero!

I’ve made a few attempts but it turns out none of the buttons are registering while learning, so I can’t finish the setup. The turning knobs do register. Also (and I should have mentioned this earlier), none of the buttons light up (except for the shift button).
When I use Komplete Kontrol the top 3 buttons do light up (Shift, Scale and ARP), but not the 3 rows underneath…
So now I’m wondering whether I’ve received a malfunctioning device. Or is it just that the Kontrol doesn’t communicate with Cubase as long as there is no integration update? How I do I determine this? If I have to wait for the update to find out if it works I might not be able to return the device.

Thanks for the time you took to make the video. Even if it doesn’t work right now, I will take advantage of it at some future date.

There might be a software thing where the A49 is running a setup against a software.

On my controller the panorama p4. It has its own setup running, wich is controlled by a software bridge with cubase. I have to select internal controll if I want it to act as a normal midi controller. Else it will only transmit basic midi things like keys, mod and pitch.

You can try and monitor the midi, by setting up a midi channel with the A49 as input and use the midi monitor insert plugin.


The transport might be set to mmc. So it might be worth a try and set it up in the Transport setup as a mmc slave.

I know how frustrating it is, when things dont work. So im always happy to help, when I have the time. :slight_smile:

Reflection, I’m going to try your latest suggestions, thanks. Meanwhile, I got this reply from a user on the NI forum:

“The A series transport buttons will be the same as the S series in how they function. They are “high level” controls that communicate directly with the script/daw and do not xmit MIDI. This is part of the current stream of complaints with the MK2 keyboard because the previous MK1 did xmit using the MCU protocol so any DAW that supported MCU (which is pretty much all of them) could use transport. Now, the DAW has to support OSC I believe which not many do and the older method of MCU was removed. So basically, if your DAW is not officially supported, you cannot get transport working (easily)”

Ok, I see.

You need a converter app to get the A49 to work with Cubase. Osc to midi.

You might have better luck using something like this http://www.fredrodrigues.net/gadgets/osc-to-midi-and-midi-to-osc-convertor/
But this might get complicated.

Well, I think I have no choice but to wait for NI to release the integration software. Hopefully that will resolve all issues.
Thanks for all your suggestions and time! If anything, it’s been instructive!

Yes, better to wait on update from NI.
The learning curve on using translators, mess about with routing and finding all the right settings.
Is steep.

Hello together,
I just made the same experience as bartveld.

I received my A25 on Friday and today I wanted to test it with Cubase 8 and found out that it’s not working. Then I went to the page of NI and found out that only Cubase since version 8.5 is supported by Komplete Kontrol A-Series. I also found the integration help on the NI regarding this new keyboard, but without any luck. According to their posting:
https://support.native-instruments.com/hc/de/articles/209557849-Einrichten-von-Cubase-Artist-Pro-oder-Nuendo-für-KOMPLETE-KONTROL

This should normally work. But maybe this momentarily just applies to the MK1 and MK2 Keyboards not the A-Series ??!

So I will also wait until NI publishes a support file for it… hopefully this doesn’t take to long, because I just bought Cubase 9.5 more or less only because of the A-Series support :frowning:.

I have put the question to Support: when will the integration be available and what can we do in the meantime?

I just found out in the Native Instruments Forum, that this issue might only be solved by NI Komplete Kontrol SW, so thanks for your effort anyway. But I couldn’t find out how long it will take until the update of the Komplete Kontrol SW will be :frowning:. So take a Snickers or a tea and wait…

I’m joining this discussion as I’m suffering from the same issue on Cubase Pro 10, but I also have logic X on my Mac which happens to work flawlessly with the Komplete kontrol A49 I purchased last week. I hope NI comes up with an update soon as I prefer to use Cubase.