How to make a title page

I want music to start on left hand page (page 2) because of page turns. So page 1 is a title page, and I want it to show part-name, name of piece, composer, etc; it’s therefore all text. I’ve created a page, created text frames and put in text tokens. Took ages. Fiddly. There will be more parts where I need to do this and if I’m doing it part by part, they’ll all look slightly different because I won’t be able to drag the frames to exactly the same place each time.
Surely there’s a better way to do all this, as there is in Sibelius, where it’s the work of seconds.
I looked up ‘title pages’ in the manual and here in the forum but couldn’t find anything that covers it.

piano888 you did everything right - except you should have created a “Masterpage” for the title page. That way you will be able to use it for all your parts - and they will look the same.

  1. create a new “Title” Masterpage
  2. for each part add a new page at the beginning, using your “Title” Masterpage

you will have to do this separately for the score, too.

Thanks - got that to work. Seems an awful lot of faff though; and when I amended the new Master Title page, I couldn’t get the part to pick it up. And why am I getting a red corner on the Pages bit in Engrave for page 1? I thought if I’m using a Master page, that wouldn’t happen? (The only way I could see to get the part to pick up the amended Master page was to get rid of the override and start again.)

The red triangle means you had made an override on that page already. After you have made an override, the format of that page doesn’t automatically update if you edit the master page it was originally based on. (If you think about it, in general that might not be what you intended).

IMO one “problem” with the page layout tools in Dorico is that they work pretty well when (a) you understand them and (b) you know what you want to achieve before you start the project, and can see a way to do what you want. But they aren’t so friendly if you are experimenting and/or learning.

I had cleared the red triangle, and that had deleted the previous title page I’d made.
When I inserted the new page (using the icon bottom LH corner of the Pages bit of Engrave), and told it use my new master title layout, the red triangle reappears.
What have I done wrong now? :frowning:

Don’t use Insert Page. Select the first page of music, then do an Insert Master Page Change function.

Thanks - that’s got the override (or lack of it, now) sorted. :slight_smile:
I’m trying to fathom exactly what that’s done; read the manual and am none the wiser.
I now find I’ve got a lovely title page, but the first page of music (page 2) just shows the flow title and part name, no page number, no project title, no composer; remaining pages show the part name and page number. If I click on the page icon in the righthand panel, to see what master page pages 2 and 3 think they’re using, they appear to be using the same, ‘Default / Default’. I’m happy with how pages 3 onwards look what’s going on now with page 2?
Why is it so complicated.

It would be easier to answer the question if you attach the score.

I can appreciate that; it’s not a score I want to put out publicly. I’ll see if I can abbreviate it.

Page 2 is probably using the Default page and Flow Headings. These settings are likely relevant:

They’re pretty self-explanatory once you know they’re there.

If you do “Lock frame” on the relevant pages and then delete all the notes, that will preserve the layout, which is the important information.

Great!
The formatting isn’t right - thought it was, but I found the red corners had come back. Here it is: Violin 1 and cello have title pages, violin 2 doesn’t. The title pages have their own master page, which I’ve inserted using Insert Master Page Change (as Craig F said), ‘Title page for part’ and Current Page only; then I don’t get a red corner. But then page 2 only shows what you see, when I want it to show Project title, Flow title, composer.
Thanks to all for all the time you’re putting into this - much appreciated.
Title page layout etc.zip (1.02 MB)

I’m looking at the Violin 1 part.
Page 2 uses the default master page, and Layout Options are set to Show Flow Headings Always (in the dialog I screenshotted above).
Two quick ways of resolving this:

  1. Add a master page change to page 2 to tell it to use First master page.

OR

  1. Set Layout Options as follows:

Those Layout Options aren’t ideal if you’ve got multiple flows going on, but now you know where the dialog is you can probably find something better for yourself :wink:

piano888,

I believe once you do Insert Master Page Change for your Title page, you then have to click on page 2 (where the music starts) and do another “Insert Master Page Change” and select Use Master Page First for Current Page Only. I’m pretty sure this will sort it out for you.

EDIT: Oops, just realized pianoleo has given same advice.
Screen Shot 2019-01-20 at 12.12.03 PM.png

There’s only one flow so that’s fine; I knew where the dialogue is, but I’ll read the manual to try to understand (I remain staggered at how complicated this all is) - but thanks to all of you - that’s exactly what I want! :slight_smile:

The manual won’t help when it comes to Flow Headers, as they’re (much) newer than the manual. Try pages 14-18 of the Version History, here: http://download.steinberg.net/downloads_software/Dorico_Pro_2_and_Dorico_Elements_2/2.2/Dorico_2.2_Version_History.pdf?_sp=91682a72-d090-4dca-bce6-6251e3a01ed5.1544271052128

Don’t feel bad, piano888 - dealing with Master Pages can be intimidating and confusing for most users until they get a grasp. I’m sure there are many power users who still get a surprise here and there with certain aspects of Master Pages when working on different projects. There is a power and flexibility to their use, and with that comes complexity. A great video to look at basic functionality is this one, which came out prior to Flow Headings.

https://m.youtube.com/watch?v=G6jw44a05Ro

EDIT - here is another video about Master Pages:

https://m.youtube.com/watch?v=k9I6qdKJ-zQ

OK. Another (related) query, if I may crave indulgence. Violin 2 (which needs no title page): it shows flow title on the line below the composer, though the master set which it seems to be drawing from shows flow title on the same line as composer: flow title appears to be entered twice but shows only once. I’d prefer the upper one, and to delete the lower one, but if I delete the lower one, of course I get the red triangle. But I can’t actually see what layout it’s taking the lower flow title from, anyway. So I’m still thoroughly confused.

Check your flow headings, Default flow header in Engrave mode.

Do you have your part set to show flow headers? Layout Options—Page Setup—Flows.