How to make Cubase 13 stop thinning out midi controller, like previous versions

Sorry if this has been asked again.

How to make Cubase 13 stop thinning out the midi controller when recording new midi parts, like previous versions.

I do not want this during recording:

But rather this, like the previous version:
image

I did see somebody mentioned turning the grid to “event” and drawing it. But I want it to be recorded this way, directly from the midi controller, instead of drawing with the mouse.

Hi,

Change the Ramp to the Steps, please.

Thank you.

However, it only works if I have something already in that editor so I can select and change it to jump.

The next time it goes back again.

Is there a way to change the default setting?

Hi,

You are right, the default option is Ramp, which you cannot change.

That’s really annoying. Because it’s extremely inaccurate, very far away from what I did on the controllers during recording.

I haven’t updated to Cubase 13 yet, but can’t you set the type for new events in Controller Lane Setup Menu any longer?

image

image

Yes. Although you’d have to have a midi event first, to do that.

Much more often I need to create a midi event from nothing during a midi recording.

There should’ve been a universal preference setting the default type.

I apologise for my misunderstanding of the issue, I should’ve deferred to Martin’s expertise. :slight_smile:

Hi,

You’d have to have a MIDI Part, not a MIDI Event.

You are right. :+1:

The vid I linked to below makes point at 5:03 that solved a similar problem for me—maybe it will help you. He suggests reducing the Automation Panel-Settings Reduction Level, which when not zero, thins out the points and produces the jagged lines.

Thanks but that is for audio automation. I was asking about midi controller lane.

Although the problem seemed to have solved itself I don’t know what I did.

Yes thanks for clarifying that for me. I too am able to draw smooth MIDI automation curves. And as you point out, that setting in the video doesn’t affect that at all, it’s for audio.